Bug 439314 - man ignores LC_MESSAGES
man ignores LC_MESSAGES
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 20:07 EDT by Lennart Poettering
Modified: 2008-11-21 06:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 06:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2008-03-27 20:07:00 EDT
In my locale settings LANG is de_DE@euro and LC_MESSAGES is C. However, man
always greets me in german language with UTF-8 characters. Which is broken in
two ways:

If LC_MESSAGES is C I expect english language program messages and man page
contents.

If LC_MESSAGES is C and LANG is de_DE@euro then I don't expect UTF8 output on my
screen.
Comment 1 Ivana Varekova 2008-04-01 08:07:49 EDT
mn should show Germany version of man page because of the language which is
chosen depends on LANG variable (LC_MESSAGES set the messages language) and the
encoding of the output is defined in /etc/sysconfig/i18n so this is not a bug.
Comment 2 Lennart Poettering 2008-04-01 09:53:51 EDT
Sorry, this is a bug.

The encoding should be chosen depending on the locale settings of the session,
not based on some global config option. All gettext() based applications handle
this correctly. man doesn't. It's a bug in man.

Yes, I did choose german language messages. That's why I expect german language
man page texts too. It is wrong to depend on the setting of $LANG. man should
check setlocale(LC_MESSAGES, NULL) for the locale to show man pages in. That's
how the locale system works.

BTW. man-db handles this correctly.
Comment 3 Lennart Poettering 2008-04-01 09:54:54 EDT
Ouch i must have been drunk. Let's try this again:

Yes, I did choose *english* language messages. That's why I expect *english*
language man page texts too. It is wrong to depend on the setting of $LANG. man
should check setlocale(LC_MESSAGES, NULL) for the locale to show man pages in.
That's how the locale system works.
Comment 4 Bug Zapper 2008-05-14 04:21:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Ivana Varekova 2008-05-15 08:19:39 EDT
Fixed in man-1.6f-6.fc10.
Comment 6 Lennart Poettering 2008-06-13 20:21:10 EDT
This bug still exists in man-1.6f-8.fc10. My locale settings are unchanged, and
I still get the german man pages.
Comment 7 Ivana Varekova 2008-11-21 06:06:35 EST
Thanks. Fixed in man-1.6f-14.fc11.

Note You need to log in before you can comment on or make changes to this bug.