Red Hat Bugzilla – Bug 439318
rename software transaction viewer
Last modified: 2013-03-13 01:43:05 EDT
Description of problem:
"Software transcation viewer" isn't a very meaningful description nor it is
easily translated. Maybe something like "Software Log" is better. The word
"transaction" occurs in relationship to PackageKit in more than one occasion.
Those need to be reviewed and better wordings chosen. Another example is the
cryptic message from g-p-m when I try to suspend with a "transcation" running. I
am not sure whether that comes from g-p-m or PackageKit.
The window title is "Update history" in git, and it is accessible from the
update viewer. We should just nuke the separate menuitem for it.
I've added upstream NotShowIn=GNOME;KDE;XFCE; on advice of Matthias, so that it
won't show up by default in the menus, but still can be added manually if needed
using the menu editor.
The other text you are seeing is:
ret = dbus_g_proxy_call (inhibit->priv->proxy_gpm, "Inhibit", &error,
G_TYPE_STRING, _("Software Update Applet"),
G_TYPE_STRING, _("A transaction that cannot be interrupted is running"),
I agree it isn't very clear. Better ideas welcome.
I think we should close this bug, as the main purpose has been met.
Ongoing language improvements throughout PK don't need to be tracked on a
word-by-word basis in bugzilla.