This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 439332 - root level menu item
root level menu item
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 22:41 EDT by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 23:13:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-03-27 22:41:09 EDT
Description of problem:

Pirut which was previously called Add/Remove Software was in the root level menu
making it easily accessible. Finding pk-application under system=>administration
is a bit more difficult and contradicts existing documentation. Retaining the
same  place as pirut might be worth considering.
Comment 1 Matthias Clasen 2008-03-27 23:13:34 EDT
I have removed the root level menu item when we switched from pirut to
PackageKit, since that spot is really only appropriate for an _application_
installer, which neither pirut nor pk-application are. They both install
packages, not applications.
Comment 2 Rahul Sundaram 2008-03-27 23:25:14 EDT
I have no idea how you differentiate between an application installer vs package
installer. Isn't a application contained in a package? Are you planning on a
different UI for this? More information would be good. 
Comment 3 Robin Norwood 2008-04-07 20:05:27 EDT
pk-application, pk-update, pirut, pup all expose the concept of a 'package' to
the users.  A package might include an entire application, or it might be part
of an application, or contain multiple applications, or it might not have
anything the user recognizes as an 'application'.  Basically, an 'application',
for the purposes of most GUI users, is something that appears in the menu.  The
plan is to develop an 'application' installer based upon the package
installation facilities of PackageKit.

For the time being, the decision is to be to remove the "Add/Remove Software"
option from the Applications menu.

Note You need to log in before you can comment on or make changes to this bug.