Bug 439355 - gnome-display-properties window too large for 800x600 display
gnome-display-properties window too large for 800x600 display
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 04:42 EDT by Fred New
Modified: 2014-06-18 05:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 14:34:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (130.87 KB, application/octet-stream)
2008-03-28 04:43 EDT, Fred New
no flags Details
png image of vmware running live cd, shows this problem (177.40 KB, image/png)
2008-04-05 20:44 EDT, Andrew Farris
no flags Details
full dialog view (35.79 KB, image/png)
2008-04-05 20:58 EDT, Andrew Farris
no flags Details
New screenshot (23.59 KB, image/png)
2008-04-07 04:13 EDT, Fred New
no flags Details

  None (edit)
Description Fred New 2008-03-28 04:42:16 EDT
Description of problem:
When I start System -> Preferences -> Hardware -> Screen Resolution, a window
opens that I cannot see the bottom of.  There are no buttons to click on when I
am finished.  I cannot move the window up to view the buttons.  All I can do is
click the X in the upper right corner to close the window.

Version-Release number of selected component (if applicable):
control-center-2.22.0-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. Log into Gnome with a screen resolution of 800x600.
2. System -> Preferences -> Hardware -> Screen Resolution
  
Actual results:
A big window of which I cannot see the bottom.  I can see the tops of the
following letters, I think:
plus the names and models of the monitor including <unreadable> you are using

Expected results:
A complete window with buttons I can click after I select a different resolution.

Additional info:
I think my monitor is an OEM version of a NEC A700+ (17" CRT).  Xorg-x11 has a
problem with the mga driver I am currently using, so my screen resolution is
forced smaller than what I want.
Comment 1 Fred New 2008-03-28 04:43:12 EDT
Created attachment 299441 [details]
Xorg.0.log
Comment 2 Andrew Farris 2008-04-05 20:44:05 EDT
Created attachment 301406 [details]
png image of vmware running live cd, shows this problem

The issue here is partly due to the extra 'debug info' in the screen which
should not be shown in the final release window.  However, that silly
super-size 'unknown' rectangular monitor representation is much larger than it
should be.  Its clear that size is not flowing (growing) to fill available
space, but the dialog size is fixed and too big.

That dialog also shows a Unknown as the monitor type for me on my Dell tower
machine
(http://www.smolts.org/client/show/?uuid=pub_78677281-8dfd-41a6-86f4-2460453c168d)
and the size of the white 'monitor' block in the dialog is still enormous.
Comment 3 Andrew Farris 2008-04-05 20:57:38 EDT
On the screenshot that is a vmware abstract display adapter, running on an intel
gma950 based Macbook.  My Dell machine has a Dell 1704FPT connected to nvidia
NV35 (fx5900xt).  Both show 'unknown' as monitor type, both originally detect at
800x600, and both end up with the dialog offscreen, but I realize the extra text
area is to blame for that.

@Fred: you can use system-config-display to set the resolution that GDM should
be using, and once you login it should inherit that as the user's resolution
until you change it for gnome.  If its already set for gnome and you need to get
it changed try gconf-editor to change it.

The dialog looks like the following attach when you can see it all.
Comment 4 Andrew Farris 2008-04-05 20:58:00 EDT
Created attachment 301407 [details]
full dialog view
Comment 5 Fred New 2008-04-07 04:13:36 EDT
Created attachment 301481 [details]
New screenshot

The size and usability are much better with control-center-2.22.0-4.fc9.i386.
Comment 6 Bug Zapper 2008-05-14 04:21:52 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fred New 2008-06-10 08:42:47 EDT
I still have an 800x600 display, but I haven't experienced this problem for some
time now.  I believe this bug can be considered closed as of
control-center-2.22.0-4.fc9.i386.
Comment 8 archimerged Ark submedes 2008-06-17 14:46:20 EDT
control-center-2.22.2.1-1.fc9.i386

When I set display to 640x480 so that small flash video (e.g. on nytimes.com)
is large enough to see, I can't reset the screen resolution unless I happen to
remember how many times to press SHIFT-TAB to get to the OK button.  How about
scroll bars on this dialog when it doesn't fit on the screen?

Also, there ought to be a way to remove/add resolutions from the list of sizes
tried using CTL-ALT-KEYPAD-MINUS/PLUS.  I used to use that to get magnified
view, and it had virtual desktop so that hidden buttons was not a problem, but
now there are so many different resolutions (many which give distorted images on
my display) that it is a pain.

Comment 9 Andrew Farris 2008-06-17 15:14:12 EDT
RE: comment #8 "Also, there ought to be a way to remove/add resolutions from the list of sizes
tried using CTL-ALT-KEYPAD-MINUS/PLUS."

If you want to see that get done you should post a new bug specifically for that.  It should still work right 
now when you manually configure it in the xorg.conf... but there is a movement to get rid of any need to 
manually configure X.  The resolutions currently being cycled through are all the available resolutions that 
are detected for your monitor/video combination when X starts; I doubt this dialog is the best place to 
reduce that list through manual configuration.

Note You need to log in before you can comment on or make changes to this bug.