Bug 439361 - chkconfig <name> lists usage message for unsupported service
chkconfig <name> lists usage message for unsupported service
Status: CLOSED DUPLICATE of bug 226804
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: chkconfig (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 05:22 EDT by Toralf
Modified: 2014-03-16 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 11:56:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2008-03-28 05:22:36 EDT
Description of problem:
When issuing chkconfig <name> with no extra arguments in order to check if a
service is enabled, and the service in question is missing, a chkconfig usage
message is printed. This is bit inconventient if you have setup scripts etc.
that that check if a certain service is present, and has been enabled.

In the past, chkconfig would just return with exit status 1 in this case, i.e.
have the same behaviour as for a service that's supported, but not enabled.

Version-Release number of selected component (if applicable):
1.3.30.1-1


How reproducible:
Every time

Steps to Reproduce:
1. chkconfig fakeservicename

  
Actual results:
chkconfig version 1.3.30.1 - Copyright (C) 1997-2000 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.

usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset|resetpriorities>

Exit status is 1

Expected results:
No output exit status is 1

Additional info:
I'm not interested in made-up service names like the one above of course, but I
want to be able to use chkconfig to check the status of services that are
associated with optional software components. I want exactly the same behaviour
whether these are installed and disabled, or not installed at all.
Comment 1 Bill Nottingham 2008-03-28 11:56:34 EDT

*** This bug has been marked as a duplicate of 226804 ***

Note You need to log in before you can comment on or make changes to this bug.