Bug 439365 - cups pdf produces document with a wrong paper size
Summary: cups pdf produces document with a wrong paper size
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups-pdf   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-28 10:02 UTC by markm
Modified: 2008-03-28 23:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 10:10:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description markm 2008-03-28 10:02:55 UTC
Description of problem:

Cups-pdf does not have a choice of a paper size and produces documents in wrong
size. Desired paper size is A4, but cups-pdf uses US Letter. US Letter is being
used in US, but not in Europe. Cups-pdf should allow to select default paper
size or should pick it up from locale settings.

Version-Release number of selected component (if applicable):

cups-pdf-2.4.6

How reproducible:

always
  
Actual results:

cups-pdf creates a document with a wrong paper size

Expected results:

correct paper size (selected by user or taken from locale settings)

Additional info:

I believe setting language to British English should also suggest A4 as a
default paper size :-)

Comment 1 markm 2008-03-28 10:10:51 UTC
ok, I can see that's actually problem with firefox 3 which does not allow to
change paper size, not cups-pdf. sorry for that.

Comment 2 Remi Collet 2008-03-28 17:38:47 UTC
Well. I close.

Comment 3 markm 2008-03-28 23:28:13 UTC
Well. The problem exists, but I am not sure, where the problem is.

Basically:

in Printers settings I've selected paper size A4.

in Manfield (Firefox 3 beta) Page Settings I've selected paper size A4.

now I want to print a page using cups-pdf and... I get a PDF with paper size US
Letter.

any thoughts?

Firefox 2 works fine - there is paper size selection on a printing dialog, but
it has been removed from Manfield - not sure if that is a Fedora's issue or
should I post it on bugzilla @ mozilla.org?

Many thanks,
Marek


Note You need to log in before you can comment on or make changes to this bug.