Bug 439368 - Cannot connect to system-configured network
Cannot connect to system-configured network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-28 06:26 EDT by David Woodhouse
Modified: 2008-03-31 14:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 14:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2008-03-28 06:26:15 EDT
I have my wireless connection configured in /etc/sysconfig/network-scripts,
including a (40-bit hex) key in /etc/sysconfig/network-scripts/keys-eth1

NetworkManager should apparently be able to connect using this automatically,
but cannot. Worse, since I used the connection editor to remove the 'Auto
Baythorne Wavelan' connection from the list to see if that helps, I cannot
connect to the network at all -- NetworkManager can't use the system
configuration, and won't recreate one of its own.
Comment 1 David Woodhouse 2008-03-28 06:29:44 EDT
NetworkManager: <info>  eth1: Device is fully-supported using driver
'b43-pci-bridge'.
NetworkManager: <info>  eth1: driver supports SSID scans (scan_capa 0x01).
NetworkManager: <info>  Now managing wireless (802.11) device 'eth1'.
NetworkManager: <info>  Bringing down device eth1
NetworkManager: <info>  Bringing up device eth1
NetworkManager: <info>  Deactivating device eth1.
NetworkManager: <info>  (eth1): exported as
/org/freedesktop/Hal/devices/net_00_0a_95_f3_99_92
NetworkManager: <info>  (eth1) supplicant interface is now in state 2 (from 1).
NetworkManager: <info>  Activation (eth1) starting connection 'System Baythorne
Wavelan (eth1)'
NetworkManager: <info>  Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info>  Activation (eth1) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info>  Activation (eth1) Stage 2 of 5 (Device Configure)
scheduled...
NetworkManager: <info>  Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <info>  Activation (eth1) Stage 2 of 5 (Device Configure)
starting...
NetworkManager: <info>  Activation (eth1/wireless): access point 'System
Baythorne Wavelan (eth1)' has security, but secrets are required.
NetworkManager: <info>  Activation (eth1) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <WARN>  get_secrets_cb(): Couldn't get connection secrets:
dbus-settings.c.115 - Secrets were found for setting '802-11-wireless-security'
but none were valid..
NetworkManager: <info>  Activation (eth1) failed for access point (Baythorne
Wavelan)
NetworkManager: <info>  Marking connection 'System Baythorne Wavelan (eth1)'
invalid.
NetworkManager: <info>  Activation (eth1) failed.
NetworkManager: <info>  Deactivating device eth1.
NetworkManager: <WARN>  nm_device_802_11_wireless_disable_encryption(): error
setting key for device eth1: No such file or directory
Comment 2 Dan Williams 2008-03-29 08:03:18 EDT
Fixed upstream in svn r3508.  Problem was that the system settings service
didn't recognize KEY, but was looking for KEY0, KEY1, KEY2, and KEY3.  For a
quick workaround, change the KEY in your keys file to KEY0.
Comment 3 Dan Williams 2008-03-29 17:05:02 EDT
Turns out ifup-wireless uses KEY1...KEY4 though, which I've just fixed the
system settings service to use in SVN, so you'll either want to not change
anything and wait for the rawhide update, or work around it now and then
s/KEY0/KEY1 after the rawhide update or it'll end up failing again.
Comment 4 Dan Williams 2008-03-31 14:11:52 EDT
svn3521 in rawhide contains the real fix

Note You need to log in before you can comment on or make changes to this bug.