Bug 439371 - findstoragedriverinsys () line 354: "sh: cd: slaves: No such file or directory"
Summary: findstoragedriverinsys () line 354: "sh: cd: slaves: No such file or directory"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: s390x Linux
high
high
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Milan Zázrivec
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks: 460823
TreeView+ depends on / blocked
 
Reported: 2008-03-28 11:04 UTC by Milan Zázrivec
Modified: 2008-09-01 15:27 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0437
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:26:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0437 normal SHIPPED_LIVE mkinitrd bug fix and enhancement update 2008-05-20 13:11:44 UTC

Description Milan Zázrivec 2008-03-28 11:04:14 UTC
Description of problem:
New installation of RHEL5.2-Server-20080326.0 on a s390x
system:
When creating initrd for installed kernel, mkinitrd stays
cycling in an infinite loop causing the whole installation
to fail.

The problem is findstoragedriverinsys() routine and this while-loop:

while [ ! -L device ]; do
            if [ -L subsystem ];then
                cd slaves;
                for x in *;do
                    if [ -L $x ]; then
                        cd $x;
                        break
                    fi;
                done
            fi
        done

This is the layout of /sys/block/dm-0:
/sys/block/dm-0
/sys/block/dm-0/slaves
/sys/block/dm-0/slaves/dasda2
/sys/block/dm-0/slaves/dasdb1
/sys/block/dm-0/slaves/dasde1
/sys/block/dm-0/slaves/dasdf1
/sys/block/dm-0/slaves/dasdg1
/sys/block/dm-0/slaves/dasdd1
/sys/block/dm-0/slaves/dasdh1
/sys/block/dm-0/slaves/dasdc1
/sys/block/dm-0/holders
/sys/block/dm-0/subsystem
/sys/block/dm-0/stat
/sys/block/dm-0/size
/sys/block/dm-0/removable
/sys/block/dm-0/range
/sys/block/dm-0/dev
/sys/block/dm-0/uevent

The while loop gets to /sys/block/dm-0/slaves/dasda2
and cycles in an infinite loop.

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-27

Comment 1 RHEL Product and Program Management 2008-03-28 12:03:27 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 2 James Laska 2008-03-28 12:03:54 UTC
Looks just like what I'm seeing when testing gfs2 partition installs (bug#438743)?

Comment 6 Peter Jones 2008-03-28 21:37:02 UTC
Fixed in mkinitrd-5.1.19.6-28 .

Comment 8 Milan Zázrivec 2008-03-31 07:01:05 UTC
Verified with mkinitrd-5.1.19.6-28

Comment 10 errata-xmlrpc 2008-05-21 15:26:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0437.html



Note You need to log in before you can comment on or make changes to this bug.