Bug 439387 - HP dc7800 desktop needs undocumented boot flag pci=conf1
HP dc7800 desktop needs undocumented boot flag pci=conf1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Tony Camuso
Red Hat Kernel QE team
:
Depends On:
Blocks: RHEL5u2_relnotes
  Show dependency treegraph
 
Reported: 2008-03-28 09:56 EDT by Ole Holm Nielsen
Modified: 2012-10-01 16:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 16:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ole Holm Nielsen 2008-03-28 09:56:55 EDT
Description of problem:
When installing any RHEL release, the booting from DVD freezes after a few
seconds while detecting PCI devices. We have found out that Linux must be booted
as follows:
boot: linux pci=conf1
This information should be added to the redhat.com | Certified Hardware page
https://hardware.redhat.com/show.cgi?id=427817

Version-Release number of selected component (if applicable):
RHEL Desktop 5.2 Beta (and all previous releases)

How reproducible:
Always

Steps to Reproduce:
1. Insert RHEL DVD into HP dc7800 desktop PC
2. Boot from DVD
3.
  
Actual results:
Booting freezes after 5-10 seconds

Expected results:
Normal installation of RHEL should proceed

Additional info:
The HP dc7800 desktop PC is Certified and Supported by RedHat, see
https://hardware.redhat.com/show.cgi?id=427817
Workaround: append the boot flag pci=conf1
Comment 1 Tony Camuso 2008-03-28 11:50:45 EDT
Ole, 

You should use the documented pci=nommconf and be able to boot the system. 

Peter, 

I believe this is not the problem where the Northbridge does not respond to
MMCONF cycles, but rather the problem where the PCI bus sizing code temporarily
maps the graphics device BAR into the MMCONF area, thereby causing the apparent
hang. 

For this problem, we maintained a blacklist for 5.2, but the DC7800 is not in
the list.

The MMCONF patch I backported from upstream for 4.7 fixes this problem, as well
as the Northbridge problem. 

I have already requested to backport that patch for 5.3

For the dc7800 in 5.2, I could submit a patch that includes dc7800 in the
existing blacklist of platforms whose BIOS maps MMCONF into regions that can be
temporarily claimed by a device BAR during PCI bus sizing, causing the system to
hang. 

Comment 2 Don Domingo 2008-03-30 19:15:44 EDT
appended to existing "Resolved Issue" for BZ#248186 in RHEL5.2 release notes:

<quote>
It is no longer necessary to use the kernel parameter pci=nommconf for systems
that use the AMD 8132 or HT 1000 chipsets.

Note that the system will still restrict such bridges to using the PortIO
CF8/CFC mechanism. However, bridges (including those on the same platform) that
respond correctly to MMCONFIG cycles will use MMCONFIG, provided that the
platform's BIOS correctly supports MMCONFIG.

<emphasis>
However, if you are installing Red Hat Enterprise Linux 5.2 on an HP DC7800, you
will still need to use the kernel parameter pci=nommconf. This is because the HP
DC7800 is not yet included in the MMCONF blacklist.
</emphasis>

</quote>

please advise if any further revisions are required. thanks!
Comment 3 Ole Holm Nielsen 2008-03-31 04:49:58 EDT
Thanks a lot for the information.  Can I request that the pci=nommconf
information gets added to the page "Certification – HP Compaq dc7800 Convertible
Minitower" https://hardware.redhat.com/show.cgi?id=427817 ?

In this way your customers have an easy way to locate this crucial information.

Looking ahead, I'm told that vendors will announce the next generation of
desktops in the May-June timeframe, so it would be great if RedHat would enter
such installation information for the new models by the time they hit the
market. Presumable the HP dc7900 (or whatever it will be called) will need the
same workaround as the dc7800 and previous models.

Comment 4 Peter Martuccelli 2008-03-31 09:28:40 EDT
Tony please submit the patch to blacklist the dc7800 for R5.2.  
Comment 5 Tony Camuso 2008-03-31 09:36:11 EDT
I'm waiting to gain access to a dc7800 for tests or to get someone from the
dc7800 team. 

There is also a disk performance problem (ssee BZ 439391)

At first I thought these problems were related, but after latest comments from
customer in BZ 439391, I'm not sure. 
 
Comment 6 Don Domingo 2008-03-31 18:18:05 EDT
just a quick FYI: i'm restricting the release note item for this to only appear
in the x86-64 version of RHEl5.2 release notes. only read the Hardware field for
this bug this morning, sorry. 

anyhow, not sure who to talk to about documenting this in hardware.redhat.com.
perhaps release-engineering? 
Comment 7 Ole Holm Nielsen 2008-04-01 04:00:00 EDT
Your customers definitely need a link in the "redhat.com | Certified Hardware
Certification – HP Compaq dc7800 Convertible Minitower" page
https://hardware.redhat.com/show.cgi?id=427817 which points to documentation of
the pci=nommconf flag !  Even though I have googled for pci=nommconf, I'm still
unaware of any authoritative RedHat information documenting this flag.
Even if the problem eventually gets fixed in RHEL 5.2, such information is
nevertheless vital for customers installing RHEL on this type of hardware.
Comment 8 Don Domingo 2008-04-01 22:17:51 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 9 Ole Holm Nielsen 2008-04-02 03:07:18 EDT
The release notes pointed to in Comment #8 are unavailable to customers :-(

I suggest that the Intel Q35 Express chipset (and any other chipsets needing the
workaround) get mentioned in the release notes. Hopefully there exists an
*authoritative* page where the pci=nommconf flag is described ?

The hardware.redhat.com pages for certified hardware (such as the HP dc7800)
should be updated with links to the page describing the pci=nommconf flag.

Comment 10 YangKun 2008-04-16 03:29:16 EDT
Hi,

A kbase reference has been added to
https://hardware.redhat.com/show.cgi?id=427817 to address this installation issue.

Thanks
-YK
Comment 11 Tony Camuso 2012-10-01 16:25:31 EDT
The kbase reference is posted in comment #10.

Closing as ERRATA

Note You need to log in before you can comment on or make changes to this bug.