Bug 439398 - F9 - Installer does not detect MacBook hardrive
F9 - Installer does not detect MacBook hardrive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9KernelBlocker
  Show dependency treegraph
 
Reported: 2008-03-28 11:17 EDT by ryan roth
Modified: 2008-05-02 06:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 06:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg dump from FC9 installer (15.45 KB, text/plain)
2008-04-24 10:21 EDT, ryan roth
no flags Details
lspci -nvv dump from fc9 installer (19.94 KB, text/plain)
2008-04-25 13:35 EDT, ryan roth
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 10512 None None None Never

  None (edit)
Description ryan roth 2008-03-28 11:17:04 EDT
Description of problem:

The Fedora 9 installer does not detect the hard drive in the MacBook.  I did a
install through F8 also and when booting the F9 kernel does not detect the hard
drive.

Version-Release number of selected component (if applicable):

Fedora 9 Beta

How reproducible:

Get a MacBook and try to install

Steps to Reproduce:
1.  Insert DVD
2.  Boot
3.  Try to install
  
Actual results:

Drive not detected

Expected results:

Drive to be detected

Additional info:

I also had the same issue when trying to compile the 2.6.25-rc5 kernel on F8. 
It would compile file but upon a reboot it would not boot because it could not
detect the drive.
Comment 1 Chuck Ebbert 2008-04-02 23:54:49 EDT
What kind of macbook? And what messages does the driver print when it loads?
Comment 2 ryan roth 2008-04-03 10:05:56 EDT
It is a two month old Santa Rosa (MacBook 4,1).  The messages all say that the
different partitions cannot be mounted, but I do not see any other errors.  It
has something to do with the sata driver I think.  I am here at your disposal to
try anything.
Comment 3 ryan roth 2008-04-23 14:59:31 EDT
This is still an issue with the FC9 Preview Release.
Comment 4 ryan roth 2008-04-23 17:40:33 EDT
This problem is still present in the 2.6.25 kernel downloaded from kernel.org

http://bugzilla.kernel.org/show_bug.cgi?id=10512
Comment 5 Chuck Ebbert 2008-04-23 21:48:48 EDT
You should be able to switch to console 2 using ctrl-alt-f2 and run the dmesg
command to see the entire kernel log. If you write that output to a USB stick
you can attach it to this bug report.
Comment 6 ryan roth 2008-04-24 10:21:58 EDT
Created attachment 303636 [details]
dmesg dump from FC9 installer
Comment 7 ryan roth 2008-04-25 13:35:41 EDT
Created attachment 303804 [details]
lspci -nvv dump from fc9 installer
Comment 9 Chuck Ebbert 2008-04-26 21:27:14 EDT
Try adding "pci=nomsi" to the kernel boot options.
Comment 10 ryan roth 2008-04-29 12:25:05 EDT
It look like this is a kernel bug related to SIDPR, we are currently testing
patches to resolve it

http://bugzilla.kernel.org/show_bug.cgi?id=10512
Comment 11 ryan roth 2008-04-29 17:21:34 EDT
What are the odds of committing the patches from the kernel.org bugzilla to the
FC9 final kernel so that we can have a working installer for laptops using this
chipset?

Thanks
Comment 12 Chuck Ebbert 2008-04-30 01:00:30 EDT
(In reply to comment #11)
> What are the odds of committing the patches from the kernel.org bugzilla to the
> FC9 final kernel so that we can have a working installer for laptops using this
> chipset?
> 

The odds are good if we can get a final patch. This bug is on the blocker list
now...

Comment 13 ryan roth 2008-04-30 10:18:09 EDT
Excellent you guys are now officially my heroes :)

Also it looks like the guys at kernel.org are almost ready for an official patch too
Comment 14 ryan roth 2008-04-30 20:58:11 EDT
There is a final patch on the kernel bugzilla page now and it is being committed
to the kernel.  The bug is officially closed there.

http://bugzilla.kernel.org/show_bug.cgi?id=10512
Comment 15 Chuck Ebbert 2008-04-30 22:02:35 EDT
Patch in 2.6.25-13

Note You need to log in before you can comment on or make changes to this bug.