Bug 439415 - don't obscure gpk-log list views with package details
don't obscure gpk-log list views with package details
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 12:30 EDT by Zack Cerza
Modified: 2008-04-27 20:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 13:13:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example screencast (99.41 KB, video/x-ogm+ogg)
2008-03-28 12:30 EDT, Zack Cerza
no flags Details
example (67.33 KB, image/png)
2008-04-21 08:46 EDT, Richard Hughes
no flags Details

  None (edit)
Description Zack Cerza 2008-03-28 12:30:27 EDT
Description of problem:
In gnome-packagekit's various list views, when an item is selected that has
details available, the text view that shows the detail is superimposed on the
list view, shortening it. This causes some confusing/irritating behavior; an
example is attached.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.9-4.fc9.i386
Comment 1 Zack Cerza 2008-03-28 12:30:27 EDT
Created attachment 299491 [details]
example screencast
Comment 2 Zack Cerza 2008-03-28 12:31:30 EDT
It's no so clear in the screencast, but all I'm doing is pressing the down key a
few times.
Comment 3 Richard Hughes 2008-03-28 14:05:40 EDT
Where should we put the extra information in your opinion?
Comment 4 Zack Cerza 2008-03-28 14:52:42 EDT
Is there a way to do it without changing the size of the list view area, e.g. by
vertically resizing the window?
Comment 5 Andrew Farris 2008-03-31 11:55:08 EDT
Just my opinion but i don't mind the resized list view when info is shown. 
Making the window suddenly get bigger is not a good idea because it may not fit
the screen, etc, and that causes weirdness when it gets sized up as big as it
can but not big enough (i.e. very narrow strip of info view, having to resize
the pane by dragging just so you can see it, etc).  This is predictable behavior
right now once you see it the first time... the window size is what you set it
to be and you can always see the info.

GTK apps have been notorious for having bad automatic resizing, especially on
smaller screens.  The 'very narrow bottom window pane' problem for instance
happens with alot of apps.
Comment 6 Andrew Farris 2008-03-31 11:57:01 EDT
Although, the info view area seems to have way too much wasted space (like
double spaced text).  Making this a much smaller info area would help the issue
of it hiding the list.
Comment 7 Zack Cerza 2008-03-31 12:12:44 EDT
Well, another option would be making it always visible. That way you know (or
can decide) up front exactly how much of everything you're going to be able to see.
Comment 8 Andrew Farris 2008-03-31 12:39:44 EDT
Yeah that would probably work out fine and would make sense because you can't do anything in the UI 
without it showing up anyway.
Comment 9 Richard Hughes 2008-04-21 08:46:23 EDT
Created attachment 303138 [details]
example

What about something like this?
Comment 10 Zack Cerza 2008-04-21 11:54:49 EDT
Actually, I think it should be the way gpk-update-viewer works currently in F9
(info pane always visible) for two reasons: Consistency with the way lists are
presented in gpk elsewhere (vertically, not horizontally), and consistency in
the way gpk provides details on updates (both currently use an info pane, and
gpk-update-viewer's is now always visible).
Comment 11 Richard Hughes 2008-04-21 13:13:40 EDT
I've committed the new UI: http://people.freedesktop.org/~hughsient/temp/gpk-log.png

It's way easier to read, and is much more HIG friendly. This is in master, not
stable, so will appear in 0.2.0.
Comment 12 Andrew Farris 2008-04-21 15:52:03 EDT
Could the sub-text of each transaction (package names) be made to wrap at the window size and stretch 
that list element down?  Then if a user increases the window size they will get fewer text wrapped lines, 
but even with a small window it does not force side scrolling like that to read the whole list of things that 
changed.

With the huge number of updates in rawhide I understand that will be a messier window with the 
wrapping, but for release versions it will be much nicer (get 10 updated packages, you'll see the ten 
package names right there and not have to scroll).
Comment 13 Richard Hughes 2008-04-27 17:51:49 EDT
That's what I want too - but that requires writing a custom renderer (no support
in GTK) and it's no small task.
Comment 14 Andrew Farris 2008-04-27 20:08:04 EDT
I see, well that support would be a great addition to GTK then, especially if it could be pushed upstream, 
so much more fluid UIs can be developed that properly flow to dynamic window sizes.  I know that has 
been a longstanding limitation with the toolkit, so hopefully someone able to contribute to that can get it 
done.  Cheers.

Note You need to log in before you can comment on or make changes to this bug.