Bug 439421 - Hard to read arabic fonts
Hard to read arabic fonts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 13:12 EDT by Sami Wagiaalla
Modified: 2016-06-07 18:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 02:08:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
arabic font in f8 (12.72 KB, image/png)
2008-03-28 13:13 EDT, Sami Wagiaalla
no flags Details
arabic font in f7 (14.38 KB, image/png)
2008-03-28 13:13 EDT, Sami Wagiaalla
no flags Details

  None (edit)
Description Sami Wagiaalla 2008-03-28 13:12:41 EDT
The arabic font in f8 is very hard to read, I have reinstalled the package from f7.
Comment 1 Sami Wagiaalla 2008-03-28 13:13:22 EDT
Created attachment 299499 [details]
arabic font in f8
Comment 2 Sami Wagiaalla 2008-03-28 13:13:48 EDT
Created attachment 299500 [details]
arabic font in f7
Comment 3 Nicolas Mailhot 2008-03-28 15:40:54 EDT
You'll be happy to learn that the F9 default font is stated to change to DejaVu
(full), which includes arabic, and will take precedence over whatever we used
before. However I suspect that you may not like it much either – its design was
constrained by lack of support for OpenType BASE
(http://bugzilla.gnome.org/show_bug.cgi?id=346419)

Users being so sensitive to font choices, I don't think we can change font
defaults of a released distribution, and it's getting awfully late to do
anything but tweaking for F9 (fixing a few glyphs right and left). Please test
and report problems early in release cycles if you're not satisfied with our
choices of defaults. (or propose changes to apply to Fedora Devel at F9 release
time ie the start of the F10 cycle)
Comment 4 Rahul Bhalerao 2008-03-31 09:31:34 EDT
sami,
 There are several fonts included for arabic that come from two parent groups,
paktype and kasct.Can you please provide the name of the particular fonts
selected in both the cases?
Comment 5 Sami Wagiaalla 2008-03-31 11:57:38 EDT
> Can you please provide the name of the particular fonts
> selected in both the cases?

How do I find out what it is ?

btw i tried this:

$rpm -q fonts-arabic
fonts-arabic-2.1-2.fc8

$rpm -ql fonts-arabic
(contains no files)

Thats a little strange isnt it ?
Comment 6 Sami Wagiaalla 2008-03-31 13:34:02 EDT
(In reply to comment #3)
> You'll be happy to learn that the F9 default font is stated to change to DejaVu

I tried rawhide and it looks the same as f8 
Comment 7 Rahul Bhalerao 2008-04-01 00:58:22 EDT
> $rpm -ql fonts-arabic
> (contains no files)
> 
> Thats a little strange isnt it ?

That is because, fonts-arabic package has been deprecated since f8. It was split
in two packages, paktype-fonts and kacst-fonts. Now fonts-arabic is only a
metapackage that installs these two packages. 
Comment 8 Nicolas Mailhot 2008-04-01 08:22:31 EDT
Also the fonts we use for arabic as not necessarily pulled by fonts-arabic (it's
only there as compatibility for people who used to have it installed).

In the future fonts needed to support a particular language will be declared in
the comps group associated with this language (for example arabic-support)

http://cvs.fedoraproject.org/viewcvs/comps/

This is what is supposed to be exposed to end users in the installers/software
updaters.
Comment 9 Sami Wagiaalla 2008-04-01 10:22:11 EDT
> That is because, fonts-arabic package has been deprecated since f8. It was split
> in two packages, paktype-fonts and kacst-fonts. Now fonts-arabic is only a
> metapackage that installs these two packages.

Ah I see.

So I removed one package then the other it looks like I was complaining about
kacst-fonts, paktype-fonts is a little better since it is not bold but it is
still  not as good as the font used in f7. That is the font used in standard
print (newspapers, books, etc)
Comment 10 Sami Wagiaalla 2008-04-01 10:24:04 EDT
> In the future fonts needed to support a particular language will be declared in
> the comps group associated with this language (for example arabic-support)
> 
> http://cvs.fedoraproject.org/viewcvs/comps/
> 
> This is what is supposed to be exposed to end users in the installers/software
> updaters.

Nice. That would be much better than yum install '*arabic*' which always cause
problems for me.
Comment 11 Rahul Bhalerao 2008-04-02 07:15:15 EDT
May be kacst-book is the font that you are looking for. May be there is a
problem with the font selection done by fontconfig. Anyway since this bug is not
indeed a fonts-arabic bug and problem appears with fontconfig, I am reassigning
it to fontconfig.
Comment 12 Bug Zapper 2008-05-14 04:22:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Jens Petersen 2008-07-11 03:46:27 EDT
(In reply to comment #9)

> So I removed one package then the other it looks like I was complaining about
> kacst-fonts, paktype-fonts is a little better since it is not bold but it is
> still  not as good as the font used in f7. That is the font used in standard
> print (newspapers, books, etc)

Hmm, I wonder what font you miss from F7?
I am not aware of any changes for Arabic since then, except that the fonts
were moved to separate packages are Rahul explained.

Perhaps you could try fonts-arabic from f7 again and see if that makes a difference:
since the paths to the fonts changed and might potentially have affected
the priorities.

Should we make kacst-fonts optional for Arabic?
Comment 14 Tony Fu 2008-09-09 23:08:19 EDT
requested by Jens Petersen (#27995)
Comment 15 Jens Petersen 2008-09-10 22:39:36 EDT
Someone is planning to submit Arabeyes fonts to fedora which may be an improvement?
Comment 16 Sami Wagiaalla 2009-02-24 12:51:03 EST
Hey guys,

Any updates on this ?
This is still present in F10
Comment 17 Jens Petersen 2009-02-25 01:46:32 EST
As usual no word from Behdad...

Sami, what font you want to see/use by default?  Does dejavu workforyou?

What is your testcase?
Comment 18 Jens Petersen 2009-02-25 01:56:45 EST
Please include the output of "rpm -qa \*fonts\* | sort"

eg http://ar.wikipedia.org/ looks ok to me on a default F10 and rawhide installs currently.
Comment 19 Sami Wagiaalla 2009-02-25 11:16:57 EST
Yes, I tried it on another f10 and it looked fine. I found that I had paktype-fonts-2.0-2.fc8.noarch installed removed it and the page looked fine. I installed dejavu and it looks even better.

I must have been carrying old settings since I did an upgrade

Thanks

Note You need to log in before you can comment on or make changes to this bug.