Bug 439465 - Jabber plugin missing due to libidn not being found in /lib
Jabber plugin missing due to libidn not being found in /lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On: 439549
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 14:49 EDT by Gerwin Krist
Modified: 2008-03-30 04:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.0.3-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 23:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerwin Krist 2008-03-28 14:49:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4

Description of problem:
When I want to add a Jabber account the option is missing in the list. I only see the following services:

- Aim
- Gadu-Gadu
- Groupwise
- ICQ
- MSN
- QQ
- SMS
- TESTBED
- WinPopup
- Yahoo

I have the qca2 and qca-ossl rpms installed ...



Version-Release number of selected component (if applicable):
kopete-0.50.1

How reproducible:
Always


Steps to Reproduce:
1.Start Kopete
2.Add account
3.

Actual Results:
Missing "Jabber" service

Expected Results:
"Jabber" should be in the list :)

Additional info:
Comment 1 Rex Dieter 2008-03-28 22:24:27 EDT
Confirmed.  
rats, it *was* there in a recent build
Comment 2 Kevin Kofler 2008-03-28 22:50:58 EDT
The build log for 4.0.3-1.fc9 says:
/builddir/build/BUILD/kdenetwork-4.0.3/kopete/protocols: Disabled Jabber 
because libidn-devel was not found
...
+ IDN: GNU Libidn Internationalized Domain Name (IDN) implemenation 
<http://www.gnu.org/software/libidn/>
Used by the Kopete Jabber plugin.
Comment 3 Kevin Kofler 2008-03-28 22:54:05 EDT
libidn-devel is BRed, but not found. :-(

Probably due to:
* Fri Mar  7 2008 Joe Orton <jorton@redhat...> 0.6.14-6
- drop libidn.a
- move shared library to /lib{,64} (#283651)

We'll have to patch the cmake file to find it there, unless we can get 
the -devel .so symlink moved back to /usr.
Comment 4 Kevin Kofler 2008-03-28 23:02:57 EDT
Grrr, this is actually being searched for using pkgconfig, but the file is not 
where pkgconfig says it is. I'm going to file a bug against libidn about that, 
but for now I'll work around it.
Comment 5 Kevin Kofler 2008-03-28 23:10:44 EDT
Filed bug 439549 against libidn.
Comment 6 Kevin Kofler 2008-03-28 23:24:45 EDT
Ugh, my first patch attempt doesn't work. :-(
Comment 7 Kevin Kofler 2008-03-28 23:35:00 EDT
Another patch committed, hopefully this one will work.
Comment 8 Gerwin Krist 2008-03-30 04:35:27 EDT
I can confirm that in the last rawhide update Jabber support is back!

Note You need to log in before you can comment on or make changes to this bug.