Bug 439467 - pcsc-lite loses track of card "IsPresent" status in some situations [NEEDINFO]
pcsc-lite loses track of card "IsPresent" status in some situations
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pcsc-lite (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bob Relyea
Depends On: 210827
  Show dependency treegraph
Reported: 2008-03-28 14:53 EDT by Ray Strode [halfline]
Modified: 2014-04-22 16:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-04-22 16:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (rstrode)

Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2008-03-28 14:53:47 EDT
+++ This bug was initially created as a clone of Bug #210827 +++
-- Additional comment from ckannan@redhat.com on 2008-03-13 18:21 EST --
ok. Saw these notes in the errata. 
bug 210827:

1) configure system for smart card/username-password login
2) go to login screen
3) insert smart card
4) while the text entry field is grayed out and you see 3 dots (this is when
pam_pkcs11 is connecting to the card), remove the smart card

If the timing is right, you'll get an "Authentication Failed" message with the
old packages, but not with the new ones

-- Additional comment from ckannan@redhat.com on 2008-03-13 18:23 EST --
So I tried the steps mentioned in comment #17. Exactly when I see the ...(3dots), 
I pulled out the smart card. After that the gdm login screen is unable to
recognize insertion/removal events. 

re-assigning back to Ray to see why ...

-- Additional comment from ckannan@redhat.com on 2008-03-26 18:05 EST --
ray enabled gdm debug logging and I wasn't able to reproduce this problem. 
Feels like this is very much related to timing. Ray will continue to investigate

-- Additional comment from rstrode@redhat.com on 2008-03-28 14:49 EST --
So, I spent some time banging on this yesterday, while talking to Chandra, Jack
and Bob on irc.

I couldn't reproduce the problem Chandra is seeing exactly (not surprising since
it's apparently timing related), but there is another similiar issue we ran into.

If you remove and insert the card 32 times (that is 16 removes and 16 inserts)
then PK11_IsPresent() from that point on will always return false which means
neither gdm nor pam_pkcs11 will see the card inserted anymore.

At any rate, that problem and Chandra's problem in comment 18 are independent of
the original issue, so we should file them as separate bugs (tentatively against
pcsc-lite i guess until we figure out where in the stack the problem is).

Those issues aren't likely to get resolved for 5.2 since they're problems with
components not on the approved component list and it's so late in the
development cycle.
Comment 1 Ludovic Rousseau 2008-03-29 04:12:27 EDT
PCSC lite has many resources limited to 16. So if gdm (or another layer) is consuming resources without 
freeing them when needed you can have a problem.

In such a case the PCSC function (SCardEstablishContext() for example) should return SCARD_E_NO_MEMORY
Comment 2 RHEL Product and Program Management 2008-06-02 16:11:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 5 RHEL Product and Program Management 2009-03-26 13:12:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Chandrasekar Kannan 2009-08-05 15:35:06 EDT
per bug council, proposing for rhel 5.5
Comment 9 RHEL Product and Program Management 2014-03-07 08:46:24 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Note You need to log in before you can comment on or make changes to this bug.