Bug 439529 - eclipse crash upon opening file
eclipse crash upon opening file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 17:19 EDT by Dominick Grift
Modified: 2008-03-31 09:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 13:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log1 (82.51 KB, application/octet-stream)
2008-03-28 17:22 EDT, Dominick Grift
no flags Details
log2 (82.26 KB, application/octet-stream)
2008-03-28 17:23 EDT, Dominick Grift
no flags Details
log3 (48.43 KB, application/octet-stream)
2008-03-28 17:23 EDT, Dominick Grift
no flags Details
log4 (1002.41 KB, application/octet-stream)
2008-03-28 17:28 EDT, Dominick Grift
no flags Details
log5 (1002.51 KB, application/octet-stream)
2008-03-28 17:29 EDT, Dominick Grift
no flags Details
log6 (713.29 KB, application/octet-stream)
2008-03-28 17:30 EDT, Dominick Grift
no flags Details

  None (edit)
Description Dominick Grift 2008-03-28 17:19:55 EDT
Description of problem:
When i try to open a file in Eclipse the program crashes with the following message:

JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.2.R331_v20071019/eclipse_1021.so
-startup /usr/share/eclipse/startup.jar
-exitdata 3a0013
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar

later i wasnt able to start eclipse at all:

JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.2.R331_v20071019/eclipse_1021.so
-startup /usr/share/eclipse/startup.jar
-exitdata 410020
-consolelog
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 

!SESSION 2008-03-28 22:18:14.513 -----------------------------------------------
eclipse.buildId=M20071023-1652
java.version=1.6.0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -consolelog

!ENTRY org.eclipse.update.configurator 2008-03-28 22:18:15.333
!MESSAGE Could not install bundle plugins/org.eclipse.pde.build/   Bundle
"org.eclipse.pde.build" version "3.3.2.R331_v20071019" has already been
installed from: update@plugins/org.eclipse.pde.build_3.3.2.R331_v20071019/

!ENTRY org.eclipse.core.resources 2 10035 2008-03-28 22:18:15.875
!MESSAGE The workspace exited with unsaved changes in the previous session;
refreshing workspace to recover changes.
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000000000bafe95, pid=12827, tid=1089505616
#
# Java VM: OpenJDK 64-Bit Server VM (1.6.0-b06 mixed mode linux-amd64)
# Problematic frame:
# V  [libjvm.so+0x5a6e95]
#
# An error report file with more information is saved as:
# /home/dgrift/hs_err_pid12827.log
#
# If you would like to submit a bug report, please visit:
#   http://icedtea.classpath.org/bugzilla
#

Version-Release number of selected component (if applicable):
eclipse-platform-3.3.1.1-17.fc9.x86_64

How reproducible:
i was able to repoduce this by reloading a project into eclipse and opening an
included file in eclipse

Steps to Reproduce:
1.load a project
2.try to open a file
3.
  
Actual results:
crash with aforementioned message

Expected results:
open the file

Additional info:
java-1.6.0-openjdk-plugin-1.6.0.0-0.5.b06.fc9.x86_64
java-1.6.0-openjdk-1.6.0.0-0.5.b06.fc9.x86_64
Comment 1 Dominick Grift 2008-03-28 17:22:43 EDT
Created attachment 299522 [details]
log1
Comment 2 Dominick Grift 2008-03-28 17:23:24 EDT
Created attachment 299523 [details]
log2
Comment 3 Dominick Grift 2008-03-28 17:23:49 EDT
Created attachment 299524 [details]
log3
Comment 4 Dominick Grift 2008-03-28 17:28:44 EDT
Created attachment 299525 [details]
log4
Comment 5 Dominick Grift 2008-03-28 17:29:45 EDT
Created attachment 299526 [details]
log5
Comment 6 Dominick Grift 2008-03-28 17:30:21 EDT
Created attachment 299527 [details]
log6
Comment 7 Dominick Grift 2008-03-29 10:40:48 EDT
This was fixed with today's updates. Please ignore, sorry for any inconvenience
caused by this.
Comment 8 Andrew Overholt 2008-03-29 13:54:03 EDT
(In reply to comment #7)
> This was fixed with today's updates. Please ignore, sorry for any inconvenience
> caused by this.

Any idea what update fixed it?  There were no java or Eclipse-related updates
today AFAIK.
Comment 9 Dominick Grift 2008-03-30 08:33:56 EDT
i think this:

Mar 29 14:57:13 Updated: 1:java-1.6.0-openjdk-1.6.0.0-0.6.b08.fc9.x86_64

(but now i have another similar issue somewhere else. see my other bz)
Comment 10 Andrew Overholt 2008-03-31 09:26:35 EDT
Lillian/Tom:  do you think this is an OpenJDK bug?

Note You need to log in before you can comment on or make changes to this bug.