Bug 439589 - system-config-keyboard
Summary: system-config-keyboard
Status: CLOSED DUPLICATE of bug 437290
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-keyboard   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-29 12:51 UTC by Flóki Pálsson
Modified: 2009-01-07 18:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 20:25:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
runing system-config-keyboard (729 bytes, text/plain)
2008-03-29 12:51 UTC, Flóki Pálsson
no flags Details
system-config-keyboard - and SElinux (4.48 KB, text/plain)
2008-03-29 23:28 UTC, Flóki Pálsson
no flags Details

Description Flóki Pálsson 2008-03-29 12:51:50 UTC
Description of problem:
Not possible to change keyboard


Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.14-1.fc9.noarch



How reproducible:
Always 

Steps to Reproduce:
1.
Install , choose IS as kyboard, fc9 beta - update all
2.
run system-config-keyboard in terminal
3.
  
Actual results:
error see Attachment

Expected results:
change keyboarlayout 

Additional info:

Comment 1 Flóki Pálsson 2008-03-29 12:51:50 UTC
Created attachment 299568 [details]
runing system-config-keyboard

Comment 2 Flóki Pálsson 2008-03-29 23:28:57 UTC
Created attachment 299599 [details]
system-config-keyboard - and SElinux

Comment 3 Flóki Pálsson 2008-03-29 23:31:08 UTC
I reinstald FC9 beta , uppdted all.
SELinux in permissive  mod
1.
run system-config-keyboard in terminal
Se result in attachment 



Comment 4 Flóki Pálsson 2008-03-29 23:32:01 UTC
Now Keyboard is IS or iclandic

Comment 5 Flóki Pálsson 2008-03-30 11:59:29 UTC
It is possible to change keyboard if SELinux is in permessive mode 

Comment 6 Daniel Walsh 2008-03-30 17:31:35 UTC
I don't believe the failure has anything to do with SELinux.

You ran the command in permissive mode, so this is not an SELinux issue.


Comment 7 Klaus Pedersen 2008-04-01 22:17:53 UTC
I have the same problem (changing to danish keyboard). 

Comment #6 is correct the SELinux error occurs only because
system-config-keyboard want to write to .xsession-errors. 

The real error is because there are no CoreKeyboard / keyboard InputDevice in
xorg.conf.

I managed to solve the prob. for me by adding:

Section "ServerLayout"
...
	InputDevice    "Generic Keyboard" "CoreKeyboard"
...
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "dk"
EndSection


Comment 8 Flóki Pálsson 2008-04-04 22:28:16 UTC
It is now possible to change keyboard with system-config-keyboard.

In yumex under Languages the list of languages in not order same order as the
alfabet.  
Files for lot off languages is missing. Icelandic Support,  Danish Support..  

Comment 9 Lubomir Kundrak 2008-04-11 20:25:21 UTC

*** This bug has been marked as a duplicate of 437290 ***


Note You need to log in before you can comment on or make changes to this bug.