Bug 439592 - excessive snd_printdd debug output from cs46xx card in 2.6.24 kernels
excessive snd_printdd debug output from cs46xx card in 2.6.24 kernels
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 09:17 EDT by Oliver Henshaw
Modified: 2008-04-29 16:54 EDT (History)
0 users

See Also:
Fixed In Version: kernel-2.6.24.5-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 12:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Last 100 lines from dmesg (7.64 KB, text/plain)
2008-03-29 09:17 EDT, Oliver Henshaw
no flags Details

  None (edit)
Description Oliver Henshaw 2008-03-29 09:17:05 EDT
Description of problem:

Since updating to the 2.6.24 kernels in f8, the cs46xx sound card driver has
become much more verbose. It seems to be printing messages every time the sound
card does anything remotely interesting. This makes it harder to look for
genuinely interesting events. Something seems to have changed so that the
snd_printdd debug messages in the cs46xx code are now being output. I've
re-checked and confirmed that the sound driver is quiet in kernel-2.6.23.15-137.fc8.

I don't know if something changed centrally in the sound system, or if it's that
more verbose debugging was turned on in the configuration. I did notice this
http://lkml.org/lkml/2008/2/17/74 - which could have similar causes.


Additional info:

Just as an indication of the scale of the debug noise:
# wc -l /var/log/messages-20080323
19819 /var/log/messages-20080323
# grep cs46xx /var/log/messages-20080323 | wc -l
13138


Version-Release number of selected component (if applicable):

kernel-2.6.24.3-12.fc8    }
kernel-2.6.24.3-34.fc8    }  all of
kernel-2.6.24.3-50.fc8    }
Comment 1 Oliver Henshaw 2008-03-29 09:17:05 EDT
Created attachment 299573 [details]
Last 100 lines from dmesg
Comment 2 Chuck Ebbert 2008-04-02 23:48:18 EDT
Disabled sound debug messages in 2.6.24.4-74
Comment 3 Fedora Update System 2008-04-21 20:04:44 EDT
kernel-2.6.24.5-85.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-22 18:43:13 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3260
Comment 5 Fedora Update System 2008-04-29 16:54:34 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.