Bug 439606 - Smolt crashes when locale is sv
Smolt crashes when locale is sv
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 11:41 EDT by Eskil Bylund
Modified: 2009-09-21 17:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 12:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes the broken po-file. (479 bytes, patch)
2008-03-29 11:41 EDT, Eskil Bylund
no flags Details | Diff
message from computer (688 bytes, text/plain)
2008-07-15 16:30 EDT, Morgan Olausson
no flags Details

  None (edit)
Description Eskil Bylund 2008-03-29 11:41:48 EDT
Description of problem:
Smolt (and firstboot) crashes when the locale is set to sv.

From firstboot:
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/firstboot/loader.py", line 87, in
loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/smolt.py", line 29, in <module>
    t = gettext.translation('smolt', '/usr/share/locale', fallback = True)
  File "/usr/lib64/python2.5/gettext.py", line 480, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib64/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.5/gettext.py", line 316, in _parse
    plural = v[1].split('plural=')[1]
IndexError: list index out of range

Version-Release number of selected component (if applicable):
smolt-1.1.1.1-1.fc9.noarch
Comment 1 Eskil Bylund 2008-03-29 11:41:48 EDT
Created attachment 299581 [details]
Fixes the broken po-file.
Comment 2 Bug Zapper 2008-05-14 04:24:23 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Morgan Olausson 2008-07-15 16:30:52 EDT
Created attachment 311883 [details]
message from computer
Comment 4 Eskil Bylund 2009-02-02 07:51:05 EST
This bug exists in Fedora 10 as well.
Comment 5 Jonas Jonsson 2009-02-12 17:05:00 EST
This bug exists in Fedora 11 Alpha as well.
Comment 6 Mike McGrath 2009-06-22 14:47:25 EDT
Ok, there's two bugs going on here, I think this one will be fixed with the next release (in the next week or two)
Comment 7 Piotr Drąg 2009-07-10 17:48:14 EDT
Bug caused by wrong plural forms should be fixed in next release of Smolt.

http://git.fedorahosted.org/git/?p=smolt.git;a=commit;h=47f7fe817f15f8603e50a7b33f3a4d166e68ec39
Comment 8 Piotr Drąg 2009-07-31 09:50:52 EDT
Can this bug report be closed now?
Comment 9 Piotr Drąg 2009-08-29 17:37:38 EDT
Could you please confirm that it is fixed in Fedora 12 Alpha?
Comment 10 Eskil Bylund 2009-08-30 17:02:33 EDT
Sorry for the delay. It seems like the package in F12 Alpha/rawhide (1.3-2.fc12.noarch) needs to be updated to the latest version (1.3.2) which contains the fix.
Comment 11 Mike McGrath 2009-09-02 11:57:51 EDT
Can someone verify that 1.3-2 is throwing an error?  I just tested in rawhide with no errors

LANG=sv smoltSendProfile -a

I'm planning on releasing 1.3.3 prior to F12, just giving the translators time to translate.
Comment 12 Jonas Jonsson 2009-09-02 14:25:22 EDT
Using smolt 1.3-1.fc11 and running
$ LANG="sv_SE.UTF-8" python /usr/share/firstboot/modules/smolt.py

gives me the reported error.
Comment 13 Mike McGrath 2009-09-03 12:43:24 EDT
1.3.2 is building for rawhide now.
Comment 14 Mike McGrath 2009-09-08 10:44:24 EDT
Ok, just did a yum update, tested firstboot and everything seems to be working.

Can someone else please verify this and close the ticket?
Comment 15 Eskil Bylund 2009-09-08 12:19:42 EDT
I can verify that it's working with 1.3.2.

Note You need to log in before you can comment on or make changes to this bug.