Bug 439619 - ppc kernel hardware watchpoint support
ppc kernel hardware watchpoint support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://ozlabs.org/pipermail/linuxppc-...
:
Depends On: 437970 444076
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 13:33 EDT by Jan Kratochvil
Modified: 2013-03-07 19:55 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.24.5-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream fix. (3.89 KB, patch)
2008-03-29 13:33 EDT, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description Jan Kratochvil 2008-03-29 13:33:11 EDT
+++ This bug was initially created as a clone of Bug #437970 +++

Description of problem:
There was a request to support hardware watchpoints (such as being used by GDB).

Version-Release number of selected component (if applicable):
It is a fresh upstream fix, so far all the kernel ppc/ppc64 variants had it broken.

How reproducible:
99% of runs with enough (>16) threads (set by THREADS).

Steps to Reproduce:
1. wget -O ppc-dabr-race.c
'http://sources.redhat.com/cgi-bin/cvsweb.cgi/~checkout~/tests/ptrace-tests/tests/ppc-dabr-race.c?cvsroot=systemtap'
2. gcc -o ppc-dabr-race ppc-dabr-race.c -Wall -ggdb2 -m32 -D_GNU_SOURCE -pthread
3. ./ppc-dabr-race ;echo $?

Actual results:
1
Tested on: ppc03.englab.brq.redhat.com
kernel-2.6.25-0.121.rc5.git4.fc9.ppc64
Dual:
cpu             : POWER5 (gr)
clock           : 1502.496000MHz
revision        : 2.2 (pvr 003a 0202)

Expected results:
0

Additional info:
Compile with -DDEBUG to see why it fails.
It was discussed upstream with IBM, mail threads at:
  http://ozlabs.org/pipermail/linuxppc-dev/2007-November/thread.html#46951
  http://ozlabs.org/pipermail/linuxppc-dev/2008-March/thread.html#52788

-m64 has the same error as -m32.

Return code 77 means the kernel/CPU combo does not support hardware watchpoints.

-- Additional comment from roland@redhat.com on 2008-03-28 17:40 EST --
See upstream commit a2ceff5e555e664751bc653a4d9b133efa18c742,
seems to have fixed it.
Comment 1 Jan Kratochvil 2008-03-29 13:33:11 EDT
Created attachment 299587 [details]
Upstream fix.
Comment 2 Dave Jones 2008-03-29 13:53:49 EDT
added to cvs, will be in next build.
Comment 3 Fedora Update System 2008-04-21 20:04:42 EDT
kernel-2.6.24.5-85.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-22 18:43:10 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3260
Comment 5 Fedora Update System 2008-04-29 16:54:32 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.