Bug 439638 - Default initial konsole width seems to be 78 chars
Summary: Default initial konsole width seems to be 78 chars
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-29 22:28 UTC by Mary Ellen Foster
Modified: 2008-04-09 17:44 UTC (History)
4 users (show)

Fixed In Version: 4.0.3-6.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 10:14:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 160422 None None None Never

Description Mary Ellen Foster 2008-03-29 22:28:21 UTC
Description of problem:
When I open a konsole in the KDE live image, it comes up as 78x24 (on my small
laptop screen) or 78x40-ish (on my larger desktop screen). It would be nice if
it started at 80 characters wide -- "yum", for instance, seems to assume an
80-character screen and does some nasty wrapping if it's smaller.

There does seem to be some upstream magic in which konsole remembers its size
across invocations instead of the "old" way of setting default size -- some
discussion about this in http://bugs.kde.org/show_bug.cgi?id=152385 and
http://bugs.kde.org/show_bug.cgi?id=155603. I guess I'm mostly requesting that
the *initial* default size be 80 characters, at least.

(Wild-ass guess: is the scrollbar maybe getting in the way and eating a couple
of columns?)

Version-Release number of selected component (if applicable):
(KDE live image)

How reproducible:
Every time

Steps to Reproduce:
1. Open a konsole without ever having resized a konsole before
2. Konsole opens to default (or last-seen) size
  
Actual results:
Default size is 78 characters wide

Expected results:
Default size should be (at least) 80 characters

Comment 1 Mary Ellen Foster 2008-04-05 19:24:07 UTC
Fixed upstream, see external link.

Comment 2 Kevin Kofler 2008-04-05 19:33:41 UTC
We probably want to backport the upstream fix for Fedora 9, reopening.

Comment 3 Kevin Kofler 2008-04-09 17:44:32 UTC
*** Bug 437197 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.