This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 439640 - No setup for German keyboard layout possible.
No setup for German keyboard layout possible.
Status: CLOSED DUPLICATE of bug 437290
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 18:44 EDT by Dieter Spahn
Modified: 2009-01-07 13:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 16:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dieter Spahn 2008-03-29 18:44:46 EDT
Description of problem:
I'm not able to setup the German keyboard layout via the 
System > Administration > Keyboard command.

Version-Release number of selected component (if applicable):


How reproducible:
Allways

Steps to Reproduce:
1. Select System > Administration > Keyboard.
2. Enter the root password.
3. Nothing happens, no dialog appears which allows me to change the
keyboard layout.
  
Actual results:
Keyboard layout is still set up for the 'us' layout.

Expected results:
Dialog to change the keyboard layout from 'us' to 'de'.

Additional info:
Comment 1 Need Real Name 2008-04-03 18:00:43 EDT
Works for me. Do you have networking up to install the dictionaries?
What if you run system-config-keyboard from a shell?
Comment 2 Julian Hofmann 2008-04-07 05:45:50 EDT
There seems to be the same problem here (on x86_64): during installation I
selected "German, nodeadkeys" -- it was ignored.

System -> preferences -> hardware -> Keyboard -> Layouts

is set to German but that doesn't help.

System -> administration -> Keyboard used to help sometimes (only until reboot)
but since some update I don't have "keyboard" in Administration any more.

On the shell system-config-keyboard opens the window needed. It is already set
to "German (latin1 w/ no deadkeys)". Klicking OK solves the problem (until
reboot) and gives 

#########################
[root@Linux1 ~]# system-config-keyboard
Loading /lib/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
Traceback (most recent call last):
  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 226, in _okClicked
    return self.apply(None, False)
  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 117, in apply
    keyboardBackend.modifyXconfig(fullname, layout, model, variant, options)
  File "/usr/share/system-config-keyboard/keyboard_backend.py", line 34, in
modifyXconfig
    keyboard = xf86config.getCoreKeyboard(xconfig)
  File "/usr/lib64/python2.5/site-packages/xf86config.py", line 177, in
getCoreKeyboard
    raise XF86SectionMissing("No CoreKeyboard InputDevice found in the layout")
xf86config.XF86SectionMissing
#################################

in the shell.

Additional information: I boot into runlevel 3. Before I startx, the layout is
fine. I bypassed the problem by adding a Section "InputDevice" to the xorg.conf
Comment 3 Fred New 2008-04-11 10:34:12 EDT
Comment #2 indicates that this is a duplicate of Bug 437290.
Comment 4 Lubomir Kundrak 2008-04-11 16:26:05 EDT

*** This bug has been marked as a duplicate of 437290 ***

Note You need to log in before you can comment on or make changes to this bug.