Bug 439643 - uvcvideo busted on x86-64
uvcvideo busted on x86-64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kyle McMartin
Fedora Extras Quality Assurance
:
: 439658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 19:04 EDT by Dave Jones
Modified: 2015-08-31 23:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 12:46:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-03-29 19:04:52 EDT
uvcvideo is one of the most common oopses reported at kerneloops..
http://www.kerneloops.org/oops.php?number=4254

The line that's causing the oops is in uvc_get_video_ctrl

        frame = &format->frame[ctrl->bFrameIndex - 1];
        ctrl->dwMaxVideoFrameSize = frame->dwMaxVideoFrameBufferSize;

It seems that frame ends up being a poison value causing the 2nd line to go boom
Comment 1 Dave Jones 2008-03-29 22:14:19 EDT
*** Bug 439658 has been marked as a duplicate of this bug. ***
Comment 2 Brandon Philips 2008-04-09 15:13:02 EDT
Dave-

The fix is trivial and in r199 in SVN.

Thanks,

Brandon
Comment 3 Kyle McMartin 2008-04-09 15:33:38 EDT
My testing last night confirms this. rev 200 should be in kernels built from
today (once I finish build testing.)

cheers, Kyle
Comment 4 Dave Jones 2008-04-14 12:46:52 EDT
This should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.