Bug 439646 - Firefox doesn't know Rhythmbox can handle itms protocol links
Summary: Firefox doesn't know Rhythmbox can handle itms protocol links
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-30 00:14 UTC by vfiend
Modified: 2018-04-11 09:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 15:29:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 426358 None None None Never

Description vfiend 2008-03-30 00:14:14 UTC
One of the big new features in Rhythmbox is that it can handle itunes podcast
feeds using the itms protocol. It even installs a firefox plugin in the default
install to better handle this ('iTunes Application Detector').

This apparently works fine in Epiphany since rhythmbox is associated with
/desktop/gnome/url-handlers/itms. However, clicking an example itms link such as
http://phobos.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=207870198 in
firefox asks for an application since firefox is not aware of this. Users should
not manually have to know to navigate to /usr/bin/rhythmbox

Comment 1 Matěj Cepl 2008-04-01 15:29:23 UTC
We filed this bug to the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=426358) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.


Comment 2 Tom (moz-triager) 2008-04-02 23:16:37 UTC
Which version of Firefox are you using?  This has been fixed in trunk:

https://bugzilla.mozilla.org/show_bug.cgi?id=388701

Can you try with either fx3b4 or a nightly (warning: you may want to back up
your profile first)?

Comment 3 Matěj Cepl 2008-04-03 06:09:26 UTC
(In reply to comment #2)
> Which version of Firefox are you using?  This has been fixed in trunk:
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=388701
> 
> Can you try with either fx3b4 or a nightly (warning: you may want to back up
> your profile first)?

Of course, being your (employed ;-)) colleague bug triager for Mozilla I have
FF3b5 and there it has been already fixed.

BTW, thanks and welcome on the board. Catching slips like this is unbelievably
helpful. Thanks!


Note You need to log in before you can comment on or make changes to this bug.