Bug 439657 - The nouveau driver in rawhide is buggy and causes kernel oopses
Summary: The nouveau driver in rawhide is buggy and causes kernel oopses
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9KernelBlocker
TreeView+ depends on / blocked
 
Reported: 2008-03-30 01:18 UTC by Arjan van de Ven
Modified: 2008-04-18 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 02:24:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arjan van de Ven 2008-03-30 01:18:35 UTC
Description of problem:

The nouveau driver in the rawhide kernel has a bug and is in the top 10 of 
kernel oopses:

http://www.kerneloops.org/searchweek.php?search=do_sys_open

This is caused by nouveau returning "1" somewhere for an error rather than "-
1". The effect of this bug is that the kernel doesn't recognize this as an 
error condition and considers this a real pointer.. which it then follows in 
do_sys_open, with an oops as result.

Most likely candidate is:

+       if (ret) {
+               DRM_ERROR("Unable to initialize the mmio mapping (%d). "
+                         "Please report your setup to " DRIVER_EMAIL "\n",
+                         ret);
+               return 1;
+       }

Comment 1 Dave Airlie 2008-03-31 04:49:26 UTC
oops sorry Arjan clicked the wrong bug...


Note You need to log in before you can comment on or make changes to this bug.