Bug 439664 - Rhythmbox and Xmms no sound
Rhythmbox and Xmms no sound
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 22:52 EDT by David Highley
Modified: 2008-05-21 10:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Highley 2008-03-29 22:52:00 EDT
Description of problem:
No sound with either Rhythmbox or Xmms music players.


Version-Release number of selected component (if applicable):
alsa-lib-devel-1.0.15-1.fc8
alsa-lib-1.0.15-1.fc8
alsa-lib-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-utils-1.0.15-1.fc8
bluez-utils-alsa-3.20-6.fc8
rhythmbox-0.11.3-7.fc8
xmms-1.2.10-36.fc7

How reproducible:


Steps to Reproduce:
1.Just try either player with ogg music files
2.
3.
  
Actual results:


Expected results:


Additional info:
Tvtime, mplayer, and other video applications seem to be fine. The sound
detection utility is also working. The System->Administration->Hardware->Sound
utility also does not work.

Checked dmesg and /var/log/messages and see nothing logged. Saw a minro squawk
when I ran rhythmbox from the command line:
(rhythmbox:7120): Rhythmbox-WARNING **: Failed to invoke RequestName: Connection
":1.15" is not allowed to own the service "org.gnome.Rhythmbox" due to SELinux
policy

(rhythmbox:7120): Rhythmbox-WARNING **: Got unhandled reply 49 from RequestName

(rhythmbox:7120): Rhythmbox-WARNING **: Unable to start mDNS browsing: MDNS
service is not running

Put Selinux in permissive mode and the squawks stopped but it still does not work.

Sound hardware is a Platinum Audigy card.
Comment 1 David Highley 2008-04-05 11:17:56 EDT
This is not the right component for this issue but I do not know how the sound
system is layered to assign it to the right component.
Comment 2 David Highley 2008-04-11 11:02:56 EDT
Can we get a status update on the bug? Is is applied to the right component? Has
the issue been pin pointed as to root cause? Thanks
Comment 3 Martin Stransky 2008-04-11 11:09:07 EDT
Seems to be rhytmbox bug. moving...
Comment 4 Bastien Nocera 2008-04-11 11:37:31 EDT
Is pulseaudio running? Do you have gstreamer-plugins-pulse installed?
Comment 5 David Highley 2008-04-11 12:49:03 EDT
How do I check for pulseaudio running? I see no process or service to run
pulseaudio. Everything was working until the recent patch updates for the alsa
packages so is there a new configuration change requirement? I have
gstreamer-plugins-pulse installed.
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
Comment 6 David Highley 2008-04-11 12:55:09 EDT
I should have also noted that I have worked around the issues by changing
System->Administration->Hardware->Sound
From autodetect to OSS for music and video. That change fixed Rythmbox and Xmms
but Vlc has its own configuration that I had to change.
Comment 7 Bastien Nocera 2008-04-14 11:07:37 EDT
If you have "alsa-plugins-pulseaudio" installed, you need to run pulseaudio to
get sound. Just type "esd &" in a terminal, and you should have sound.

It's launched automatically if you use GNOME as your desktop environment. Also
make sure that the "haldaemon" service is running so you can get permissions on
the sound devices.
Comment 8 David Highley 2008-04-14 11:47:09 EDT
First I must say why would anyone close this issue when there has been no
resolution?

The alsa-plugins-pulseaudio module was list above and I'm using Gnome sessions.
So we still have yet to discover what the change was that broke the audio to
begin with and what the right fix is.
Comment 9 David Highley 2008-04-15 04:11:54 EDT
If I run esd &. Which is a symbolic link to esdcomp a bourne shell script it
exits right away as pulseaudio is all ready running. Pulseaudio has been logging
the following since I installed Fedora 8 and they maybe stopping its functioning
now:
Apr 15 00:53:56 douglas gconfd (dhighley-8612): starting (version 2.20.1), pid 8
612 user 'dhighley'
Apr 15 00:53:56 douglas gconfd (dhighley-8612): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Apr 15 00:53:56 douglas gconfd (dhighley-8612): Resolved address
"xml:readwrite:/home/dhighley/.gconf" to a writable configuration source at
position 1
Apr 15 00:53:56 douglas gconfd (dhighley-8612): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Apr 15 00:53:57 douglas pulseaudio[8625]: core-util.c: setpriority(): Permission
denied
Apr 15 00:53:57 douglas pulseaudio[8625]: main.c: setrlimit(RLIMIT_NICE, (31,
31)) failed: Operation not permitted
Apr 15 00:53:57 douglas pulseaudio[8625]: main.c: setrlimit(RLIMIT_RTPRIO, (9,
9)) failed: Operation not permitted
Apr 15 00:53:57 douglas gconfd (dhighley-8612): Resolved address
"xml:readwrite:/home/dhighley/.gconf" to a writable configuration source at
position 0
Apr 15 00:57:00 douglas pulseaudio[8860]: core-util.c: setpriority(): Permission
denied
Comment 10 David Highley 2008-05-21 10:59:06 EDT
Solved the issue by installing additional pulse audio utilities which showed
that it was using the wrong sound card. After having several issues where a
reboot or a package update breaks an operational system I would have to say the
real bug is in the hardware detection and sorting of devices. I conclude we
should not be using in chassis boards because of this issue; everything needs to
be USB or a network resource. I believe this issue to be a bug but it would
never be accepted by development.
Comment 11 David Highley 2008-05-21 10:59:57 EDT
I should have added I had to disable the mother board audio to solve this issue.

Note You need to log in before you can comment on or make changes to this bug.