Bug 439676 - xmlgraphics-commons 1.3 wont build with java-1.6.0-openjdk
xmlgraphics-commons 1.3 wont build with java-1.6.0-openjdk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 05:52 EDT by kushaldas@gmail.com
Modified: 2008-04-02 16:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kushaldas@gmail.com 2008-03-30 05:52:20 EDT
Description of problem:fop is failing while creating the pdf


Version-Release number of selected component (if applicable):
fop-0.94-2.noarch

How reproducible: I tried in two ways, one with publican , another direct
calling the fop


Steps to Reproduce:
with publican
1. crate_book testbook
2. cd testbook
3. make pdf

direct calling:
1. fop -fo a.fo -pdf a.pdf
  
Actual results:
30-Mar-08 3:07:25 PM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-width set to: 120mm
30-Mar-08 3:07:26 PM org.apache.fop.cli.Main startFOP
SEVERE: Exception
java.lang.NullPointerException
   at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:168)
   at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:115)
   at org.apache.fop.cli.Main.startFOP(Main.java:166)
   at org.apache.fop.cli.Main.main(Main.java:196)

---------

java.lang.NullPointerException
   at gnu.xml.transform.SAXSerializer.getValue(libgcj.so.9)
   at org.apache.fop.fo.PropertyList.addAttributesToList(PropertyList.java:278)
   at org.apache.fop.fo.FObj.processNode(FObj.java:121)
   at
org.apache.fop.fo.FOTreeBuilder$MainFOHandler.startElement(FOTreeBuilder.java:320)
   at org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:185)
   at gnu.xml.transform.SAXSerializer.serialize(libgcj.so.9)
   at gnu.xml.transform.SAXSerializer.serialize(libgcj.so.9)
   at gnu.xml.transform.TransformerImpl.transform(libgcj.so.9)
   at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:165)
   at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:115)
   at org.apache.fop.cli.Main.startFOP(Main.java:166)
   at org.apache.fop.cli.Main.main(Main.java:196)



Expected results: It was supposed to create the pdf file.


Additional info:
Comment 1 Anthony Green 2008-03-30 10:46:20 EDT
On rawhide, it fails in a different way.  It can't load SVGDocument.

/usr/bin/fop should put xml-commons-apis-ext.jar on the classpath.

Now it's failing because it's missing LINEAR_RGB.pf, which appears to be part of
the JDK's colour management code.

As an experiment, I copied OpenJDK's sRGB.pf to LINEAR_RGB.pf and was able to
create a pdf document.  Unfortunately evince crashes when I try to display it. 
I don't know if it's because I'm creating a bad pdf or if evince is buggy.

BTW, the first step to reproduce should be "create_book --name testbook", not
"crate_book testbook"



java.lang.ExceptionInInitializerError
        at org.apache.batik.gvt.AbstractGraphicsNode.paint(Unknown Source)
        at org.apache.batik.gvt.ShapeNode.paint(Unknown Source)
        at org.apache.batik.gvt.CompositeGraphicsNode.primitivePaint(Unknown Source)
        at org.apache.batik.gvt.AbstractGraphicsNode.paint(Unknown Source)
        at org.apache.batik.gvt.CompositeGraphicsNode.primitivePaint(Unknown Source)
        at org.apache.batik.gvt.CanvasGraphicsNode.primitivePaint(Unknown Source)
        at org.apache.batik.gvt.AbstractGraphicsNode.paint(Unknown Source)
	at org.apache.batik.gvt.CompositeGraphicsNode.primitivePaint(Unknown Source)
	at org.apache.batik.gvt.AbstractGraphicsNode.paint(Unknown Source)
	at
org.apache.fop.render.pdf.PDFSVGHandler.renderSVGDocument(PDFSVGHandler.java:259)
	at
org.apache.fop.render.AbstractGenericSVGHandler.handleXML(AbstractGenericSVGHandler.java:67)
	at org.apache.fop.render.AbstractRenderer.renderXML(AbstractRenderer.java:813)
	at org.apache.fop.render.PrintRenderer.renderDocument(PrintRenderer.java:169)
	at org.apache.fop.render.pdf.PDFRenderer.putImage(PDFRenderer.java:1701)
	at org.apache.fop.render.pdf.PDFRenderer.renderImage(PDFRenderer.java:1652)
	at org.apache.fop.render.AbstractRenderer.renderViewport(AbstractRenderer.java:748)
	at
org.apache.fop.render.AbstractPathOrientedRenderer.renderViewport(AbstractPathOrientedRenderer.java:541)
	at
org.apache.fop.render.AbstractRenderer.renderInlineArea(AbstractRenderer.java:631)
	at org.apache.fop.render.pdf.PDFRenderer.renderInlineArea(PDFRenderer.java:1316)
	at org.apache.fop.render.AbstractRenderer.renderLineArea(AbstractRenderer.java:606)
	at org.apache.fop.render.pdf.PDFRenderer.renderLineArea(PDFRenderer.java:1307)
	at org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:532)
	at org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:582)
	at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1300)
	at org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:522)
	at org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:582)
	at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1300)
	at org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:522)
	at org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:582)
	at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1300)
	at org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:522)
	at org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:582)
	at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1300)
	at org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:522)
	at org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:582)
	at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1300)
	at org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:522)
	at org.apache.fop.render.AbstractRenderer.renderFlow(AbstractRenderer.java:427)
	at
org.apache.fop.render.AbstractRenderer.renderMainReference(AbstractRenderer.java:406)
	at
org.apache.fop.render.AbstractRenderer.renderBodyRegion(AbstractRenderer.java:340)
	at
org.apache.fop.render.AbstractRenderer.renderRegionViewport(AbstractRenderer.java:285)
	at
org.apache.fop.render.AbstractRenderer.renderPageAreas(AbstractRenderer.java:258)
	at org.apache.fop.render.AbstractRenderer.renderPage(AbstractRenderer.java:232)
	at org.apache.fop.render.pdf.PDFRenderer.renderPage(PDFRenderer.java:757)
	at org.apache.fop.area.RenderPagesModel.addPage(RenderPagesModel.java:120)
	at
org.apache.fop.layoutmgr.PageSequenceLayoutManager.finishPage(PageSequenceLayoutManager.java:424)
	at
org.apache.fop.layoutmgr.PageSequenceLayoutManager.makeNewPage(PageSequenceLayoutManager.java:377)
	at org.apache.fop.layoutmgr.PageBreaker.handleBreakTrait(PageBreaker.java:502)
	at org.apache.fop.layoutmgr.PageBreaker.getNextBlockList(PageBreaker.java:131)
	at org.apache.fop.layoutmgr.AbstractBreaker.doLayout(AbstractBreaker.java:301)
	at org.apache.fop.layoutmgr.AbstractBreaker.doLayout(AbstractBreaker.java:263)
	at
org.apache.fop.layoutmgr.PageSequenceLayoutManager.activateLayout(PageSequenceLayoutManager.java:144)
	at org.apache.fop.area.AreaTreeHandler.endPageSequence(AreaTreeHandler.java:233)
	at org.apache.fop.fo.pagination.PageSequence.endOfNode(PageSequence.java:145)
	at org.apache.fop.fo.FOTreeBuilder$MainFOHandler.endElement(FOTreeBuilder.java:378)
	at org.apache.fop.fo.FOTreeBuilder.endElement(FOTreeBuilder.java:194)
	at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown
Source)
	at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown
Source)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown
Source)
	at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown
Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown
Source)
	at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(Unknown
Source)
	at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
	at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
	at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:165)
	at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:115)
	at org.apache.fop.cli.Main.startFOP(Main.java:166)
	at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.IllegalArgumentException: Can't load standard profile:
LINEAR_RGB.pf
	at java.awt.color.ICC_Profile$2.run(ICC_Profile.java:912)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.color.ICC_Profile.getStandardProfile(ICC_Profile.java:905)
	at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:886)
	at java.awt.color.ColorSpace.getInstance(ColorSpace.java:347)
	at org.apache.batik.ext.awt.image.GraphicsUtil.<clinit>(Unknown Source)
	... 74 more
Comment 2 Jared Smith 2008-03-30 14:05:35 EDT
Two quick notes there... Kushal's problem appears to be that he's running FOP
under libgcj, not under IcedTea/OpenJDK.  As far as I know, FOP has never worked
correctly under libgcj.

As for Anthony's problem, I've never been able to get FOP to work with SVG files
under rawhide -- probably best to open a separate bug for that one, if there's
not already one open.
Comment 3 kushaldas@gmail.com 2008-03-30 14:50:16 EDT
That case fop must depend on OpenJDK, a regular user may not know about OpenJDK.
I am trying to install it. Will reply after couple of minutes.
Comment 4 kushaldas@gmail.com 2008-03-30 15:05:34 EDT
Ok, with OpenJDK , the following came


[kd@blackbox testbook]$ make pdf

WARNING: PRODUCT is set to the default setting of 'Documentation', are you sure
this is correct?
        Run 'make help_params' for more information on this setting

START: xml-en-US Mon Mar 31 00:27:02 IST 2008
        copying common/en-US Common_Content
        copying common/en-US Common_Content
cleaning files
        Appendix.xml
        Author_Group.xml
        Book_Info.xml
        Chapter.xml
        Preface.xml
        Revision_History.xml
        testbook.xml
END: xml-en-US Mon Mar 31 00:27:04 IST 2008
START: test-en-US Mon Mar 31 00:27:04 IST 2008
warning: failed to load external entity "tmp/en-US/xml/Feedback.xml"
END: test-en-US Mon Mar 31 00:27:05 IST 2008
START: pdf-en-US Mon Mar 31 00:27:05 IST 2008
warning: failed to load external entity "Feedback.xml"
Making portrait pages on A4 paper (210mmx297mm)
Mar 31, 2008 12:27:09 AM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-height set to: 240mm
Mar 31, 2008 12:27:09 AM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-width set to: 120mm
Mar 31, 2008 12:27:11 AM org.apache.fop.image.analyser.SVGReader$Loader getImage
WARNING: Batik not in class path
java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:637)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
        at org.apache.batik.dom.svg.SVGDOMImplementation.createDocument(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.startElement(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDriver.scanRootElementHook(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.createDocument(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.createDocument(Unknown
Source)
        at org.apache.batik.dom.svg.SAXSVGDocumentFactory.createDocument(Unknown
Source)
        at
org.apache.batik.dom.svg.SAXSVGDocumentFactory.createSVGDocument(Unknown Source)
        at
org.apache.fop.image.analyser.SVGReader$Loader.getImage(SVGReader.java:132)
        at
org.apache.fop.image.analyser.SVGReader$Loader.access$000(SVGReader.java:110)
        at org.apache.fop.image.analyser.SVGReader.loadImage(SVGReader.java:94)
        at
org.apache.fop.image.analyser.SVGReader.verifySignature(SVGReader.java:64)
        at
org.apache.fop.image.analyser.ImageReaderFactory.make(ImageReaderFactory.java:85)
        at org.apache.fop.image.ImageFactory.loadImage(ImageFactory.java:220)
        at org.apache.fop.image.ImageLoader.loadImage(ImageLoader.java:56)
        at org.apache.fop.image.ContextImageCache.getImage(ImageFactory.java:432)
        at org.apache.fop.image.ImageFactory.getImage(ImageFactory.java:157)
        at org.apache.fop.fo.flow.ExternalGraphic.bind(ExternalGraphic.java:70)
        at org.apache.fop.fo.FObj.processNode(FObj.java:125)
        at
org.apache.fop.fo.FOTreeBuilder$MainFOHandler.startElement(FOTreeBuilder.java:320)
        at org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:185)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(Unknown
Source)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(Unknown Source)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:165)
        at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:115)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.ClassNotFoundException: org.w3c.dom.svg.SVGDocument
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
        ... 65 more
END: pdf-en-US Mon Mar 31 00:27:12 IST 2008
Comment 5 Lillian Angel 2008-03-31 10:12:07 EDT
I am rebuilding fop to require java-1.6.0-openjdk.

Do you have Batik installed? It seems odd that it is giving this message
"WARNING: Batik not in class path"
Comment 6 Lillian Angel 2008-03-31 10:20:54 EDT
I found a problem with JAVA_HOME. I fixed this in the spec file. This will be in
rawhide tomorrow, could you test it out and report back?
Comment 7 kushaldas@gmail.com 2008-03-31 10:26:02 EDT
Batik is installed in my system.
Can I try the latest package from koji ?
Comment 8 Jared Smith 2008-03-31 10:29:45 EDT
I'd be happy to test the updated package from tomorrow's rawhide (or from koji,
if the package has already been rebuilt).
Comment 9 Lillian Angel 2008-03-31 10:32:17 EDT
sure- http://koji.fedoraproject.org/koji/buildinfo?buildID=44364
Comment 10 kushaldas@gmail.com 2008-03-31 10:45:31 EDT
I installed and tried,, result is almost same



[kd@blackbox testbook]$ make pdf

WARNING: PRODUCT is set to the default setting of 'Documentation', are you sure
this is correct?
        Run 'make help_params' for more information on this setting

START: xml-en-US Mon Mar 31 20:07:04 IST 2008
        copying common/en-US Common_Content
        copying common/en-US Common_Content
cleaning files
        Appendix.xml
        Author_Group.xml
        Book_Info.xml
        Chapter.xml
        Preface.xml
        Revision_History.xml
        testbook.xml
END: xml-en-US Mon Mar 31 20:07:06 IST 2008
START: test-en-US Mon Mar 31 20:07:06 IST 2008
warning: failed to load external entity "tmp/en-US/xml/Feedback.xml"
END: test-en-US Mon Mar 31 20:07:07 IST 2008
START: pdf-en-US Mon Mar 31 20:07:07 IST 2008
warning: failed to load external entity "Feedback.xml"
Making portrait pages on A4 paper (210mmx297mm)
Mar 31, 2008 8:07:11 PM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-height set to: 240mm
Mar 31, 2008 8:07:11 PM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-width set to: 120mm
Mar 31, 2008 8:07:14 PM org.apache.fop.image.analyser.SVGReader$Loader getImage
WARNING: Batik not in class path
java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:637)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
        at org.apache.batik.dom.svg.SVGDOMImplementation.createDocument(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.startElement(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDriver.scanRootElementHook(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.createDocument(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.createDocument(Unknown
Source)
        at org.apache.batik.dom.svg.SAXSVGDocumentFactory.createDocument(Unknown
Source)
        at
org.apache.batik.dom.svg.SAXSVGDocumentFactory.createSVGDocument(Unknown Source)
        at
org.apache.fop.image.analyser.SVGReader$Loader.getImage(SVGReader.java:132)
        at
org.apache.fop.image.analyser.SVGReader$Loader.access$000(SVGReader.java:110)
        at org.apache.fop.image.analyser.SVGReader.loadImage(SVGReader.java:94)
        at
org.apache.fop.image.analyser.SVGReader.verifySignature(SVGReader.java:64)
        at
org.apache.fop.image.analyser.ImageReaderFactory.make(ImageReaderFactory.java:85)
        at org.apache.fop.image.ImageFactory.loadImage(ImageFactory.java:220)
        at org.apache.fop.image.ImageLoader.loadImage(ImageLoader.java:56)
        at org.apache.fop.image.ContextImageCache.getImage(ImageFactory.java:432)
        at org.apache.fop.image.ImageFactory.getImage(ImageFactory.java:157)
        at org.apache.fop.fo.flow.ExternalGraphic.bind(ExternalGraphic.java:70)
        at org.apache.fop.fo.FObj.processNode(FObj.java:125)
        at
org.apache.fop.fo.FOTreeBuilder$MainFOHandler.startElement(FOTreeBuilder.java:320)
        at org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:185)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(Unknown
Source)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(Unknown Source)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:165)
        at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:115)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.ClassNotFoundException: org.w3c.dom.svg.SVGDocument
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
        ... 65 more
END: pdf-en-US Mon Mar 31 20:07:15 IST 2008
Comment 11 Lillian Angel 2008-03-31 10:48:23 EDT
ok thanks, i will look into this more.
Comment 12 Lillian Angel 2008-03-31 11:15:53 EDT
After more digging I found out this is a problem with Batik. 

org/w3c/dom/svg/ directory is in batik-all-1.6.jar, I don't see it
inside batik-all-1.7.jar..
Comment 13 Lillian Angel 2008-03-31 11:52:44 EDT
Fop just released 0.95 beta which is compatible with batik-1.7. I will update to
this version.
Comment 14 Lillian Angel 2008-03-31 13:25:51 EDT
To build fop 0.95, xmlgraphics-commons needs to be updated to 1.3.
xmlgraphics-commons-1.3 does not build with java-1.6.0-openjdk.

I am reassigning the bug to java-1.6.0-openjdk components.
Comment 15 Lillian Angel 2008-04-01 09:23:07 EDT
Fixed. Both fop and java-1.6.0-openjdk will be in rawhide within the next couple of days.
Comment 16 kushaldas@gmail.com 2008-04-01 09:36:34 EDT
Please provide the koji build URLs here , so that we can test them
Comment 17 Lillian Angel 2008-04-01 09:45:26 EDT
openjdk takes 12 hours to build. they wont be done for quite some time. when they are i will post them.
Comment 18 Lillian Angel 2008-04-02 10:06:27 EDT
openjdk: http://koji.fedoraproject.org/koji/buildinfo?buildID=44460
fop: http://koji.fedoraproject.org/koji/buildinfo?buildID=44501

You will need the openjdk packages for fop to work properly. I need to wait for
openjdk to make it into rawhide before I can build the updated version of
xmlgraphics-commons
Comment 19 Lillian Angel 2008-04-02 14:45:10 EDT
xmlgraphics-commons: http://koji.fedoraproject.org/koji/taskinfo?taskID=544602
Comment 20 kushaldas@gmail.com 2008-04-02 16:02:43 EDT
I just got this




Apr 3, 2008 1:24:06 AM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-height set to: 11in
Apr 3, 2008 1:24:06 AM org.apache.fop.apps.FopFactoryConfigurator configure
INFO: Default page-width set to: 8.26in
Apr 3, 2008 1:24:08 AM org.apache.fop.image.loader.batik.PreloaderSVG$Loader
getImage
WARNING: Batik not in class path
java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:637)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
        at org.apache.batik.dom.svg.SVGDOMImplementation.createDocument(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.startElement(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDriver.scanRootElementHook(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.createDocument(Unknown
Source)
        at org.apache.batik.dom.util.SAXDocumentFactory.createDocument(Unknown
Source)
        at org.apache.batik.dom.svg.SAXSVGDocumentFactory.createDocument(Unknown
Source)
        at
org.apache.batik.dom.svg.SAXSVGDocumentFactory.createSVGDocument(Unknown Source)
        at
org.apache.fop.image.loader.batik.PreloaderSVG$Loader.getImage(PreloaderSVG.java:121)
        at
org.apache.fop.image.loader.batik.PreloaderSVG$Loader.access$100(PreloaderSVG.java:104)
        at
org.apache.fop.image.loader.batik.PreloaderSVG.preloadImage(PreloaderSVG.java:72)
        at
org.apache.xmlgraphics.image.loader.ImageManager.preloadImage(ImageManager.java:165)
        at
org.apache.xmlgraphics.image.loader.cache.ImageCache.needImageInfo(ImageCache.java:96)
        at
org.apache.xmlgraphics.image.loader.ImageManager.getImageInfo(ImageManager.java:112)
        at org.apache.fop.fo.flow.ExternalGraphic.bind(ExternalGraphic.java:79)
        at org.apache.fop.fo.FObj.processNode(FObj.java:125)
        at
org.apache.fop.fo.FOTreeBuilder$MainFOHandler.startElement(FOTreeBuilder.java:286)
        at org.apache.fop.fo.FOTreeBuilder.startElement(FOTreeBuilder.java:163)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(Unknown
Source)
        at
com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(Unknown Source)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler.emptyElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:214)
        at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:125)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.ClassNotFoundException: org.w3c.dom.svg.SVGDocument
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
        ... 64 more
Apr 3, 2008 1:24:08 AM org.apache.fop.fo.flow.ExternalGraphic bind
SEVERE: Image not available: No ImagePreloader found for
Common_Content/images/title_logo.svg
Apr 3, 2008 1:24:08 AM org.apache.fop.fonts.FontInfo notifyFontReplacement
WARNING: Font 'Symbol,normal,700' not found. Substituting with 'Symbol,normal,400'.
Apr 3, 2008 1:24:08 AM org.apache.fop.fonts.FontInfo notifyFontReplacement
WARNING: Font 'ZapfDingbats,normal,700' not found. Substituting with
'ZapfDingbats,normal,400'.
Apr 3, 2008 1:24:09 AM org.apache.fop.fonts.FontInfo notifyFontReplacement
WARNING: Font 'ZapfDingbats,italic,400' not found. Substituting with
'ZapfDingbats,normal,400'.
Apr 3, 2008 1:24:09 AM org.apache.fop.fo.properties.CommonHyphenation getHyphChar
WARNING: Substituted specified hyphenation character (0x25ba) with 0x2d because
the font doesn't have the specified hyphenation character: monospace,normal,400
Apr 3, 2008 1:24:09 AM org.apache.fop.fo.properties.CommonHyphenation getHyphChar
WARNING: Substituted specified hyphenation character (0x25ba) with 0x2d because
the font doesn't have the specified hyphenation character: monospace,normal,400
Apr 3, 2008 1:24:09 AM org.apache.fop.fo.properties.CommonHyphenation getHyphChar
WARNING: Substituted specified hyphenation character (0x25ba) with 0x2d because
the font doesn't have the specified hyphenation character: monospace,normal,700
Apr 3, 2008 1:24:09 AM org.apache.fop.fo.properties.CommonHyphenation getHyphChar
WARNING: Substituted specified hyphenation character (0x25ba) with 0x2d because
the font doesn't have the specified hyphenation character: monospace,normal,400
Exception in thread "main" java.lang.ExceptionInInitializerError
        at
org.apache.fop.render.pdf.ImageRenderedAdapter.<init>(ImageRenderedAdapter.java:67)
        at
org.apache.fop.render.pdf.PDFImageHandlerRenderedImage.generateImage(PDFImageHandlerRenderedImage.java:57)
        at org.apache.fop.render.pdf.PDFRenderer.putImage(PDFRenderer.java:1745)
        at org.apache.fop.render.pdf.PDFRenderer.renderImage(PDFRenderer.java:1679)
        at
org.apache.fop.render.AbstractRenderer.renderViewport(AbstractRenderer.java:734)
        at
org.apache.fop.render.AbstractPathOrientedRenderer.renderViewport(AbstractPathOrientedRenderer.java:557)
        at
org.apache.fop.render.AbstractRenderer.renderInlineArea(AbstractRenderer.java:617)
        at
org.apache.fop.render.pdf.PDFRenderer.renderInlineArea(PDFRenderer.java:1345)
        at
org.apache.fop.render.AbstractRenderer.renderLineArea(AbstractRenderer.java:592)
        at
org.apache.fop.render.pdf.PDFRenderer.renderLineArea(PDFRenderer.java:1336)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:529)
        at
org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:564)
        at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1329)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:519)
        at
org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:564)
        at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1329)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:519)
        at
org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:564)
        at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1329)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:519)
        at
org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:564)
        at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1329)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:519)
        at
org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:564)
        at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1329)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:519)
        at
org.apache.fop.render.AbstractRenderer.renderBlock(AbstractRenderer.java:564)
        at org.apache.fop.render.pdf.PDFRenderer.renderBlock(PDFRenderer.java:1329)
        at
org.apache.fop.render.AbstractRenderer.renderBlocks(AbstractRenderer.java:519)
        at
org.apache.fop.render.AbstractRenderer.renderFlow(AbstractRenderer.java:424)
        at
org.apache.fop.render.AbstractRenderer.renderMainReference(AbstractRenderer.java:403)
        at
org.apache.fop.render.AbstractRenderer.renderBodyRegion(AbstractRenderer.java:337)
        at
org.apache.fop.render.AbstractRenderer.renderRegionViewport(AbstractRenderer.java:282)
        at
org.apache.fop.render.AbstractRenderer.renderPageAreas(AbstractRenderer.java:255)
        at
org.apache.fop.render.AbstractRenderer.renderPage(AbstractRenderer.java:229)
        at org.apache.fop.render.pdf.PDFRenderer.renderPage(PDFRenderer.java:801)
        at org.apache.fop.area.RenderPagesModel.addPage(RenderPagesModel.java:113)
        at
org.apache.fop.layoutmgr.AbstractPageSequenceLayoutManager.finishPage(AbstractPageSequenceLayoutManager.java:312)
        at
org.apache.fop.layoutmgr.PageSequenceLayoutManager.finishPage(PageSequenceLayoutManager.java:167)
        at
org.apache.fop.layoutmgr.AbstractPageSequenceLayoutManager.makeNewPage(AbstractPageSequenceLayoutManager.java:284)
        at
org.apache.fop.layoutmgr.PageBreaker.handleBreakTrait(PageBreaker.java:494)
        at org.apache.fop.layoutmgr.PageBreaker.startPart(PageBreaker.java:398)
        at
org.apache.fop.layoutmgr.AbstractBreaker.addAreas(AbstractBreaker.java:421)
        at
org.apache.fop.layoutmgr.AbstractBreaker.addAreas(AbstractBreaker.java:371)
        at org.apache.fop.layoutmgr.PageBreaker.doPhase3(PageBreaker.java:262)
        at
org.apache.fop.layoutmgr.AbstractBreaker.doLayout(AbstractBreaker.java:346)
        at
org.apache.fop.layoutmgr.AbstractBreaker.doLayout(AbstractBreaker.java:264)
        at
org.apache.fop.layoutmgr.PageSequenceLayoutManager.activateLayout(PageSequenceLayoutManager.java:106)
        at
org.apache.fop.area.AreaTreeHandler.endPageSequence(AreaTreeHandler.java:234)
        at
org.apache.fop.fo.pagination.PageSequence.endOfNode(PageSequence.java:123)
        at
org.apache.fop.fo.FOTreeBuilder$MainFOHandler.endElement(FOTreeBuilder.java:340)
        at org.apache.fop.fo.FOTreeBuilder.endElement(FOTreeBuilder.java:169)
        at
com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler.endElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown
Source)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
        at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transformIdentity(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at
com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown
Source)
        at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:214)
        at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:125)
        at org.apache.fop.cli.Main.startFOP(Main.java:166)
        at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.IllegalArgumentException: Can't load standard profile:
LINEAR_RGB.pf
        at java.awt.color.ICC_Profile$2.run(ICC_Profile.java:912)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.color.ICC_Profile.getStandardProfile(ICC_Profile.java:905)
        at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:886)
        at java.awt.color.ColorSpace.getInstance(ColorSpace.java:347)
        at
org.apache.xmlgraphics.ps.ImageEncodingHelper.<clinit>(ImageEncodingHelper.java:40)
        ... 72 more
Comment 21 kushaldas@gmail.com 2008-04-02 16:09:39 EDT
And I have batik installed in the system :(
Comment 22 Lillian Angel 2008-04-02 16:16:29 EDT
That is not right. You should see this in /usr/bin/fop:

export CLASSPATH=$CLASSPATH:/usr/share/java/xml-commons-apis-ext.jar

That jar contains the SVGDocument class. I tested it out on my system and it
works fine.
Comment 23 Lillian Angel 2008-04-02 16:33:12 EDT
For some reason, the changes didn't make it into that build. I fixed it. It
should definitely work now:

http://koji.fedoraproject.org/koji/taskinfo?taskID=544730

Note You need to log in before you can comment on or make changes to this bug.