Bug 439682 - recent mesa break SDL using opengl games which request a stencil buffer
recent mesa break SDL using opengl games which request a stencil buffer
Status: CLOSED DUPLICATE of bug 442510
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 08:33 EDT by Hans de Goede
Modified: 2008-04-18 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 18:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-03-30 08:33:49 EDT
Description of problem:
-take a fully up2date rawhide (x86_64, r350 card)
-start supertuxkart
-get this message:
FATAL: ssgInit called without a valid OpenGL context.

This goes away if you edit the source code of supertuxkart to not request a
stencil buffer, when a stencil buffer is requested the SDL_SetVideoMode() call
fails (because it cannot find a visual with a stencilbuffer I guess), so there
is no glContext, causing the above error.

Other symptoms, same problem:
-start blobAndConquer
-goto options -> additional options
-notice how shadow is not available because no stencil buffers were detected.
Comment 1 Hans de Goede 2008-04-15 04:49:19 EDT
I've filed a new bug with a better description and a patch for the supertuxkart
problem: bug 442510. This still leaves the blobAndConquer stencil buffer support
detection not working, I'll look into that as time permits.
Comment 2 Hans de Goede 2008-04-15 14:48:25 EDT
krh, adding you to the CC as I just noticed the commit causing (exposing) this
issue was done by you. Any input on howto move forward with this would be much
appreciated, currently I'm thinking about either:
* use the patch attached here
* patch applications to use / also try glXChooseFBConfig()
Comment 3 Hans de Goede 2008-04-15 14:51:18 EDT
Darn sorry krh, wrong bug, adding you to bug 442510 instead / too.
Comment 4 Hans de Goede 2008-04-18 18:53:07 EDT
bug 442510 now contains a much improved patch fixing both issues reported here,
closing this as a dup of bug 442510.

*** This bug has been marked as a duplicate of 442510 ***

Note You need to log in before you can comment on or make changes to this bug.