This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 439684 - segfault in evince (regression since f8)
segfault in evince (regression since f8)
Status: CLOSED DUPLICATE of bug 438970
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 09:01 EDT by Mat Booth
Modified: 2008-04-02 08:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 08:13:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Pdf that triggers the crash (3.02 MB, application/pdf)
2008-03-30 09:01 EDT, Mat Booth
no flags Details

  None (edit)
Description Mat Booth 2008-03-30 09:01:11 EDT
Description of problem:
Opening the attached pdf document (projector manual) in evince causes segfaults
in current Rawhide where it works perfectly in the F8 evince. The following
error is generated:

[mbooth@sd Desktop]$ evince e.pdf 
**
** ERROR:(ev-poppler.cc:868):EvLinkDest* ev_link_dest_from_dest(PdfDocument*,
PopplerDest*): assertion failed: (dest != NULL)
evince: xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) -
(dpy->request)) >= 0)' failed.
Multiple segmentation faults occurred; can't display error dialog


Version-Release number of selected component (if applicable):
evince.x86_64  2.22.0-3.fc9  installed <--Rawhide version that segfaults
evince.i386    2.20.2-1.fc8  installed <--F8 version that works

How reproducible:
Every time.

Actual results:
Evince opens briefly before disappearing without a trace.

Expected results:
Opens document as it does in F8
Comment 1 Mat Booth 2008-03-30 09:01:12 EDT
Created attachment 299624 [details]
Pdf that triggers the crash
Comment 2 Osma Ahvenlampi 2008-03-31 03:54:02 EDT
possibly dupes #438970
Comment 3 Michal Schmidt 2008-04-02 08:13:25 EDT

*** This bug has been marked as a duplicate of 438970 ***

Note You need to log in before you can comment on or make changes to this bug.