Bug 439695 - missing "No suspend signature on swap, not resuming."
Summary: missing "No suspend signature on swap, not resuming."
Status: CLOSED DUPLICATE of bug 438951
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9PR
TreeView+ depends on / blocked
 
Reported: 2008-03-30 15:34 UTC by John Reiser
Modified: 2008-04-04 01:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 01:05:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/init from initrd-2.6.25-0.172.rc7.git4.fc9.x86_64.img (1.96 KB, text/plain)
2008-03-30 19:40 UTC, John Reiser
no flags Details

Description John Reiser 2008-03-30 15:34:03 UTC
Description of problem: Console messages during boot say "Trying to resume from
<device>" but there is no comment when the attempt fails.  Fedora 8 says "No
suspend signature on swap, not resuming" to indicate cold boot (non-resume.)


Version-Release number of selected component (if applicable):
initscripts-8.67-1.x86_64


How reproducible: always


Steps to Reproduce:
1. cold boot via grub from usual ext3 partition.
2.
3.
  
Actual results: VGA Console messages:
Trying to resume from /sys/block/sda//sda5    ## 1st swap partition
   ## no indication of failure

Expected results:
Trying to resume from /sys/block/sda//sda5    ## 1st swap partition
No suspend signature on swap, not resuming.   ## indication of no resume

Additional info: kernel-2.6.25-0.172.rc7.git4.fc9.x86_64
but the problem occurs with all other f9-Beta kernels, too.

Comment 1 Jeremy Katz 2008-03-30 16:38:38 UTC
Can you unpack the initrd (zcat /boot/initrd* |cpio -id) and grab the /init
script out and attach it here?

Comment 2 John Reiser 2008-03-30 19:40:30 UTC
Created attachment 299637 [details]
/init from initrd-2.6.25-0.172.rc7.git4.fc9.x86_64.img

zcat /boot/initrd-2.6.25-0.172.rc7.git4.fc9.x86_64.img | cpio -id
## then "./init"

Comment 3 John Reiser 2008-03-30 19:44:41 UTC
initrd-2.6.25-0.121.rc5.git4.fc9.img was much the same:
# diff -u init.121 init.172
--- init.121	2008-03-30 12:41:45.000000000 -0700
+++ init.172	2008-03-30 12:42:26.000000000 -0700
@@ -67,9 +67,9 @@
 modprobe scsi_wait_scan
 rmmod scsi_wait_scan
 mkblkdevs
-resume /sys/block/sdb//sdb5
+resume /sys/block/sda//sda5
 echo Creating root device.
-mkrootdev -t ext3 -o defaults,ro /dev/sdc6
+mkrootdev -t ext3 -o defaults,ro /dev/sdb6
 echo Mounting root filesystem.
 mount /sysroot
 echo Setting up other filesystems.


Comment 4 Alex Lancaster 2008-04-03 11:19:02 UTC
I can duplicate this issue, although I get the error on a command like:

resume /sys/block/dm-3

If I extract the init script from a kernel build with an earlier version of
mkinitrd which didn't have this problem, I see something like:

resume /dev/mapper/Volume00-swap

which does resume correctly which seems to suggest that this seems to be the
same or similar issue as bug #438951 (should that bug be marked as dupe of this
one?)

Comment 5 Alex Lancaster 2008-04-04 00:29:24 UTC
Bumping severity a bit, this is a major regression IMHO.

Comment 6 petrosyan 2008-04-04 00:58:56 UTC
this looks like a duplicate of bug #438583

Comment 7 Charles R. Anderson 2008-04-04 01:05:27 UTC

*** This bug has been marked as a duplicate of 438951 ***


Note You need to log in before you can comment on or make changes to this bug.