Bug 439698 - plain listing of packages
plain listing of packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 12:06 EDT by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 13:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (33.27 KB, image/png)
2008-04-12 05:33 EDT, Richard Hughes
no flags Details

  None (edit)
Description Rahul Sundaram 2008-03-30 12:06:18 EDT
Description of problem:

There is no sorted listing of all packages without going through different
groups unlike Pirut which has this functionality in the third tab.

Additional info:

I use this to figure out which packages to remove after I have tried out several
just as an example of where this could be useful.
Comment 1 Richard Hughes 2008-03-31 07:32:20 EDT
So, you basically want a "Show all packages" button? Where would this logically
go in the UI?
Comment 2 Rahul Sundaram 2008-03-31 07:57:25 EDT
Yep. Well in Pirut it shows up in a additional tab. Somewhat similar to the UI
of pk-application before 1.10. 
Comment 3 Richard Hughes 2008-03-31 08:54:23 EDT
What about in the group selector as "All"?
Comment 4 Rahul Sundaram 2008-03-31 09:04:34 EDT
That would work as well.
Comment 5 Richard Hughes 2008-04-11 11:12:46 EDT
I've added the GetPackages method into the backends.
Comment 6 Richard Hughes 2008-04-12 05:33:59 EDT
Created attachment 302202 [details]
screenshot

This is what git looks like. This is a 0.2.x feature (because of the new API),
and so won't go into F9 for a little while. You can test it if you use my git
RPMs tho.
Comment 7 Rahul Sundaram 2008-04-12 09:23:12 EDT
I think this serves my purpose pretty well. Firefox like search as you type
would be a very good enhancement. 
Comment 8 Richard Hughes 2008-04-12 09:56:15 EDT
We can't do search as you type, as that would be a bazillion available packages
to add, cache and then search as you type. What about search-as-you-type for
previous queries?
Comment 9 Rahul Sundaram 2008-04-12 10:05:59 EDT
Search is probably the most common operation that is going to happen with the
app and shouldn't be relegated to just a search box. If we can cache more
upfront, that might help. 

Search as you type for previous queries would be a improvement too. 
Comment 10 Richard Hughes 2008-04-21 13:15:49 EDT
I'll close this as the original bug has been fixed. Bringing up search-as-you
type on the mailing list is probably the best plan.

Note You need to log in before you can comment on or make changes to this bug.