Bug 439726 - Gnome Power Manager not installed correctly?
Gnome Power Manager not installed correctly?
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-30 19:50 EDT by Austin
Modified: 2013-03-05 22:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-01 02:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Error message on the desktop. (12.91 KB, image/png)
2008-03-30 19:50 EDT, Austin
no flags Details
Details from /var/log/messages (1.58 KB, text/plain)
2008-03-30 19:51 EDT, Austin
no flags Details
/var/log/messages after trying to login (5.92 KB, text/plain)
2008-03-31 22:32 EDT, Austin
no flags Details
audit.log grepped for power messages (19.93 KB, text/plain)
2008-04-01 02:09 EDT, Austin
no flags Details

  None (edit)
Description Austin 2008-03-30 19:50:11 EDT
Description of problem:
A warning messages pops up in the corner of the desktop about the gnome power
manager not being installed correctly.

Version-Release number of selected component (if applicable):
# rpm -q gnome-power-manager

How reproducible:
Every time I try to log in.

Steps to Reproduce:
1. Log in.
2. Observe message in corner.
Actual results:

Expected results:
No message.

Additional info: Available upon request.
I'll attach some details from /var/log/messages.
Comment 1 Austin 2008-03-30 19:50:11 EDT
Created attachment 299647 [details]
Error message on the desktop.
Comment 2 Austin 2008-03-30 19:51:02 EDT
Created attachment 299648 [details]
Details from /var/log/messages

I ran grep -i power /var/log/messages and put the output in this file.
Comment 3 Matthias Clasen 2008-03-31 10:36:14 EDT
Is this with selinux enforcing ? There have been some reports about selinux
breakage in this area
Comment 4 Austin 2008-03-31 22:14:38 EDT
selinux is in permissive mode:

# getenforce 

Oh shoot - I could have _sworn_ I set that to Permissive at install time! :-/

# setenforce Permissive

I'll try that to see if the problem persists.
Comment 5 Austin 2008-03-31 22:32:50 EDT
Created attachment 299803 [details]
/var/log/messages after trying to login

I setup a separate console with tail -f /var/log/messages, and went back to my
VMWare window, where I tried to login.
I tried to login (double clicking my username from the greeter), but it
appeared unresponsive. I tried again, and observed the messages from the
separate console (which I've now attached).
Uncertain if they're applicable here, and possibly more appropriate here (bug#
Via SSH, I run 'runlevel' and I observe that it still thinks it's in runlevel
5, but certainly no GUI at this stage, and unable to login via console either.
I'll reboot (reset) the system and try again.
Comment 6 Austin 2008-03-31 22:45:11 EDT
Quite possibly fixed with SELinux set to permissive. I rebooted and was able to
login without this message.

Should this be a bug against SELinux then?
Comment 7 Matthias Clasen 2008-04-01 01:16:45 EDT
CCing dwalsh@redhat.com
Comment 8 Daniel Walsh 2008-04-01 01:47:19 EDT
Were there any AVC messages in /var/log/audit/audit.log.  If not this is
probably not an SELinux issue.
Comment 9 Austin 2008-04-01 02:09:48 EDT
Created attachment 299844 [details]
audit.log grepped for power messages

I ran this command and attached the output for you:

grep -i power /var/log/audit/audit.log 

There's 68 lines in here. I've not sorted or culled any further.
Comment 10 Daniel Walsh 2008-04-01 02:20:51 EDT
The problem is you have an unlabled file "ior" on your system the kernel reports
this with the file_t context.  This could indicate a major mislabeled machine. 
YOu can fix the entire systems labeling by executing 
# touch /.autorelabel; reboot

If you just added a disk you could run 

# restorecon -R -v DISKMOUNTPOINT

Once you fix the labeling the problem should work fine.
Comment 11 Austin 2008-04-01 02:37:15 EDT
I tried the .autorelabel thing, and I just did a search of the entire file
system for a file called "ior". Nothing. Are you certain of these diagnostics?

The system has been rebooted, and I've turned SE Linux to Permissive mode to
avoid any further problems.

This is a fresh install on a VM with no "new" disks. Perhaps somewhere along the
lines of upgrading from 9 alpha something became corrupt? SE Linux labels were
not applied for some reason?
Comment 12 Daniel Walsh 2008-04-01 04:10:40 EDT
type=AVC msg=audit(1207026237.006:27): avc:  denied  { read } for  pid=2192
comm="gnome-power-man" name="ior" dev=dm-0 ino=200780
tcontext=system_u:object_r:file_t:s0 tclass=file
type=SYSCALL msg=audit(1207026237.006:27): arch=c000003e syscall=2 success=no
exit=-13 a0=16513d0 a1=0 a2=1b6 a3=7f39fab2e7b0 items=0 ppid=2173 pid=2192
auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42
tty=(none) ses=4294967295 comm="gnome-power-man"
exe="/usr/bin/gnome-power-manager" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023

Well the avc above reports that gnome-power-manager running as xdm_t is trying
to read a file named ior labled file_t.

Are you continuing to get the AVC after relabeling?

Note You need to log in before you can comment on or make changes to this bug.