Bug 439746 - weird blank area at bottom of gvim window
weird blank area at bottom of gvim window
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
http://endbracket.net/mikel/screensho...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 23:58 EDT by Mikel Ward
Modified: 2009-01-09 02:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2008-03-30 23:58:00 EDT
I'm running vim 7.1.211-1.fc8.  I usually use the text-mode version, but today I
installed the vim-X11 package.

At the bottom of the window (where many GUI apps would have a status bar), gvim
just has an ugly gray patch that doesn't seem to do anything (see URL).

I've tried moving my ~/.vimrc out of the way and I still get the same results.
Comment 1 Karsten Hopp 2008-03-31 07:51:50 EDT
the command area has a slightly different color, type  'ESC :' to start entering
a command and you'll see that.

Try gvim -u NONE -U NONE to check if the color changes when gvim is started
without any config files.
Comment 2 Mikel Ward 2008-03-31 18:46:36 EDT
Nope, the color is still the same.  (which is expected, since gvim -u NONE -U
NONE is equivalent to moving my Vim dotfiles out of the way.)

Wouldn't it look much better if the command area was the same color as the main
buffer window?  Is the upstream version gray too?  Has Red Hat modified anything
under /usr/share/vim?

GVim on Windows
http://www.softpedia.com/progScreenshots/GVim-Portable-Screenshot-50508.html
white buffer, white command area

GVim on Mac OS X
http://homepage.mac.com/sao1/fink/screenshots/vim.html
blue buffer, blue command area
Comment 3 Mikel Ward 2008-03-31 18:51:30 EDT
Scratch that.

There's definitely something wrong.

It's not the command line ("minibuffer") at the bottom.

It's more like there's a status bar that never does anything or it's allowing
space for a default GNOME panel that doesn't exist.  (I'm running xfce.)

See new screenshot
http://endbracket.net/mikel/screenshots/gvim-gray-bottom.png
Comment 4 Mikel Ward 2008-03-31 18:55:42 EDT
Yep, weirdness goes away if I run it under a GNOME session.
Comment 5 Bug Zapper 2008-11-26 05:19:12 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-01-09 02:44:56 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.