Bug 439761 - No way to add email icon once its gone
No way to add email icon once its gone
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: launchmail (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 04:53 EDT by Toralf
Modified: 2015-05-11 08:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:19:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2008-03-31 04:53:43 EDT
Description of problem:
The launchmail desktop setup seems to be used to add and "Email" icon to the
default panel config, but does not allow you to add the icon to an existing
panel, as far as I can tell. In other words, if you remove the "Email" icon,
there is no direct way to reinsert it. The problem is that

NoDisplay=true

appears in the .desktop config file, which means that the associated entry
appears neither in the menu or in Add to Panel->Application Launcher...

Version-Release number of selected component (if applicable):
4.0.0-1.el5

How reproducible:
Every time

Steps to Reproduce:
1. In a default panel, right-click on the email launch icon and select "Remove
from Panel"
2. Try to re-add the launcher...
  
Actual results:
The email launcher does not appear as a separate item under "Add to panel...",
so you have to use "Custom Application Launcher" and type in the command by hand.

Expected results:
An entry for the email launcher appers somewhere under "Add to panel...".


Additional info:
Perhaps this is really an issue with gnome-panel and/or Desktop Entry
Specification, and what you want is a way of saying "don't show this item in the
default menu". I think that's not quite what "NoDisplay=true" means, as it is
more equivalent to "it does not make sense to start this item via menus or
launchers."

Workaround: Just remove "NoDisplay=true", and allow the entry to appear in the menu.
Comment 1 Warren Togami 2008-03-31 10:15:11 EDT
The reason it exists in this way is the result of Desktop team's decisions of
what should be in the menus.  I will not change it unilaterally.  Reassigning to
someone on the Desktop team.  This decision is not my responsibility.
Comment 2 RHEL Product and Program Management 2014-03-07 07:49:14 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:19:01 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 4 Toralf 2015-05-11 08:25:12 EDT
I keep getting emails saying that someone is waiting for my response to this issue, but I'm unsure why based on the request's status.

Note You need to log in before you can comment on or make changes to this bug.