Bug 439780 - Extremely unhelpful "Dependency resolution failed" message
Summary: Extremely unhelpful "Dependency resolution failed" message
Status: CLOSED DUPLICATE of bug 439762
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-31 12:02 UTC by vfiend
Modified: 2008-03-31 12:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 12:44:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bad dependency resolution error window (127.03 KB, image/png)
2008-03-31 12:02 UTC, vfiend
no flags Details

Description vfiend 2008-03-31 12:02:18 UTC
Description of problem: When trying to remove aiksaurus-gtk that was installed
in the default install, PackageKit tells me it "cannot be remove, because
something depends on it". Aside from the horrible grammar, PackageKit should be
able to figure out the dependencies, since yum can.


Version-Release number of selected component (if applicable): 0.1.10



# yum remove aiksaurus-gtk
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package aiksaurus-gtk.x86_64 1:1.2.1-15.fc6 set to be erased
--> Processing Dependency: libAiksaurusGTK-1.2.so.0()(64bit) for package: abiword
--> Running transaction check
---> Package abiword.x86_64 1:2.6.0-6.fc9 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 aiksaurus-gtk           x86_64     1:1.2.1-15.fc6   installed          85 k
Removing for dependencies:
 abiword                 x86_64     1:2.6.0-6.fc9    installed          19 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       2 Package(s)         

Is this ok [y/N]:

Comment 1 vfiend 2008-03-31 12:02:18 UTC
Created attachment 299712 [details]
bad dependency resolution error window

Comment 2 Richard Hughes 2008-03-31 12:44:53 UTC
I've corrected the grammar in the backend in git, thanks. PackageKit can work
out the deps on a package, but this appears to be broken in the backend. If
GetRequires worked, than you would get UI "okay to remove additional packages".

*** This bug has been marked as a duplicate of 439762 ***


Note You need to log in before you can comment on or make changes to this bug.