This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 439850 - Every install, libvirt error messages are shown on virt-install
Every install, libvirt error messages are shown on virt-install
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 14:51 EDT by Bryan Mason
Modified: 2010-10-22 19:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2008-0371
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch copied from upstream. (1.55 KB, patch)
2008-03-31 14:51 EDT, Bryan Mason
no flags Details | Diff

  None (edit)
Description Bryan Mason 2008-03-31 14:51:00 EDT
Description of problem:

    Extraneous errors from libvirt are emitted when runing
    virt-install.  The errors look to be the result of checking to see
    if the UUID and name specified by virt-install are already in use.
    The errors should be caught and ignored.

Version-Release number of selected component (if applicable):

    python-virtinst-0.300.2-5.el5

How reproducible:

    Every time

Steps to Reproduce:
    1.  Run virt-install 
  
Actual results:

    # virt-install [lots of parameters omitted for clarity]
    Starting install...
    libvir: Xen error : Domain not found: xenUnifiedDomainLookupByUUID
    libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
    Creating domain...                                             0 B 00:03

Expected results:

    # virt-install [options omitted for clarity]
    Starting install...
    Creating domain...                                             0 B 00:03

Additional info:

    This is already fixed in upstream python-virtinst with the following patch:
    http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=dc3dd659f7df
Comment 1 Bryan Mason 2008-03-31 14:51:00 EDT
Created attachment 299750 [details]
Proposed patch copied from upstream.
Comment 2 RHEL Product and Program Management 2008-03-31 14:53:14 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Daniel Berrange 2008-03-31 14:59:21 EDT
Is this really a regression, AFAIR, there was the same behaviour in RHEL-5.1
version of virt-install too.
Comment 4 Bryan Mason 2008-03-31 15:13:36 EDT
It doesn't seem to happen in RHEL 5.1:

    # rpm -q python-virtinst
    python-virtinst-0.103.0-3.el5_1.1
    # rpm -q libvirt
    libvirt-0.2.3-9.el5_1.1

    # virt-install --name=guest_dom --ram=1024 \
    >    --file=/var/lib/xen/images/it169291.img --vcpus=1 --check-cpu \
    >    --bridge=xenbr0 --mac=00:16:3e:74:36:48 --paravirt \
    >    --location
nfs:engarchive.rdu.redhat.com:/engineering/archives2/released/RHEL-5-Server/U1/i386/os
\
    >    --nographics


    Starting install...
    Creating domain...                                             0 B 00:02 
    Linux version 2.6.18-53.el5xen (brewbuilder@hs20-bc2-3.build.redhat.com)
(gcc version 4.1.2 20070626 (Red Hat 4.1.2-14)) #1 SMP Wed Oct 10 17:06:12 EDT 2007
    BIOS-provided physical RAM map:
     Xen: 0000000000000000 - 0000000040800000 (usable)

But it does in RHEL 5.2 Beta:

    # rpm -q python-virtinst
    python-virtinst-0.300.2-5.el5
    # rpm -q libvirt
    libvirt-0.3.3-5.el5
    

   # virt-install --name=guest_dom --ram=1024 \
   --file=/var/lib/xen/images/it169291.img --vcpus=1 --check-cpu \
   --bridge=xenbr0 --mac=00:16:3e:74:36:48 --paravirt \
   --location
nfs:engarchive.rdu.redhat.com:/engineering/archives2/released/RHEL-5-Server/U1/i386/os
\
   --nographics
   You are going to overwrite file '/var/lib/xen/images/it169291.img'!
   Do you really want to use the file (yes or no)?  yes


   Starting install...
   libvir: Xen error : Domain not found: xenUnifiedDomainLookupByUUID
   libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
   Creating domain...                                             0 B 00:01
   libvir: Remote error : No such file or directory
   libvir: warning : Failed to find the network: Is the daemon running ?
   Linux version 2.6.18-53.el5xen (brewbuilder@hs20-bc2-3.build.redhat.com)
   (gcc version 4.1.2 20070626 (Red Hat 4.1.2-14)) #1 SMP Wed Oct 10 17:06:12
   EDT 2007
   BIOS-provided physical RAM map:
    Xen: 0000000000000000 - 0000000040800000 (usable)

I also noticed that the problem only occurs if you upgrade _both_ libvirt and
ython-virtinst (and their dependencies) to the RHEL 5.2 Beta versions.  If you
upgrade only python-virtinst, then the messages do not appear.
Comment 7 Daniel Berrange 2008-04-01 14:42:28 EDT
Fix built into python-virtinst-0.300.2-8.el5
Comment 11 errata-xmlrpc 2008-05-21 12:45:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0371.html

Note You need to log in before you can comment on or make changes to this bug.