This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 439858 - swf mozilla plugin - no youtube
swf mozilla plugin - no youtube
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: swfdec (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 15:37 EDT by Linus Torvalds
Modified: 2014-01-21 01:10 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 08:12:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
firefox debug output (2.62 KB, text/plain)
2008-03-31 18:46 EDT, Linus Torvalds
no flags Details

  None (edit)
Description Linus Torvalds 2008-03-31 15:37:13 EDT
Description of problem:

youtube no workee - fedora 9 not usable for wife

Version-Release number of selected component (if applicable):

swfdec.x86_64                 0.6.2-1.fc9
swfdec-gtk.x86_64             0.6.2-1.fc9
swfdec-mozilla.x86_64         0.6.0-1.fc9


How reproducible:

I didn't try a lot of videos, but I couldn't find a single one that actually
worked. And what's the internet without the rick-roll?

Some just show a light gray background, some give the play buttons etc, but show
only a black screen even when the red ball at the bottom moves along..

Steps to Reproduce:
1. Install current Fedora 9
2. Rick-roll!
3. No profit!
  
Actual results:

Some videos just show a light gray background, some give the play buttons etc,
but in the latter case show only a black screen even when the red ball at the
bottom seems to moves along..

Expected results:

Rick Astley in all his glory! People have reported that youtube videos are
supposed to work with swfdec, so I presume they have worked at some point and
have been broken recently. 

Just to test that this isn't just a anti-rick-roll security feature, I also
tested some other videos, but let's face it - we do need Rick for the "Full
Internet Experience".

Additional info:

This is "high" priority because the wife will kill me if she doesn't have her
videos. And the adobe player won't install on current rawhide due to some
library issues.

"Obi-wan Kenobi, you're our only hope"
Comment 1 Brian Pepple 2008-03-31 16:24:33 EDT
Sounds like you might be missing some gstreamer plugins.  Could you provide me
the output of 'rpm -qa gstreamer-*'.  Thanks.
Comment 2 Brian Pepple 2008-03-31 17:07:43 EDT
The "black screen" bug on youtube could also be XAA problem in Xorg... switching
to EXA should fix that.
Comment 3 Linus Torvalds 2008-03-31 17:16:06 EDT
I am indeed running XAA. Intel driver:

   (==) intel(0): Using XAA for acceleration

but haven't a clue how to even test EXA (if it is even possible with the intel
driver).

as to gstreamer plugins, I already extended my set from livna because I thought
it migth be something like that, so now my list is

  gstreamer-plugins-bad-0.10.6-3.lvn9.x86_64
  gstreamer-plugins-base-0.10.18-1.fc9.x86_64
  gstreamer-plugins-good-0.10.7-1.fc9.x86_64
  gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
  gstreamer-python-0.10.11-2.fc9.x86_64
  gstreamer-tools-0.10.18-1.fc9.x86_64

but that didn't help or make any difference.
Comment 4 Linus Torvalds 2008-03-31 17:21:16 EDT
Never mind about EXA - I added 

        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"

to my xorg.conf, but that didn't really change anything at all except for the
Xorg.0.log now saying

  (**) intel(0): Using EXA for acceleration

but youtube looks the same. Does it really work for other people?
Comment 5 Brian Pepple 2008-03-31 18:03:32 EDT
(In reply to comment #4)
> but youtube looks the same. Does it really work for other people?

Yeah, I talked to some of the swfdec devs and they said it worked for some
people, but sadly doesn't seem to be the case here.

Since we've ruled out most of the obvious reasons (missing codecs, XAA), and I
can't reproduce this locally, could you post the output of stderr when your
trying to view a video on YouTube?  Hopefully, that will give me some more
information on what's causing your problem.  Thanks.
Comment 6 Bastien Nocera 2008-03-31 18:26:44 EDT
The "extended set" of plugins is still missing gstreamer-ffmpeg from livna to
allow playback of FLV videos (video codec).

FYI, firefox needs the "-debug" to spit out debug output.
Comment 7 Linus Torvalds 2008-03-31 18:37:48 EDT
Hey - gstreamer-ffmpeg makes a difference.

But I don't get any sound from this thing, so while I now can see the video, I'm
still not home scot-free. 

I know sound works, because amarok and other apps have no problem. Any clues?
Comment 8 Linus Torvalds 2008-03-31 18:46:01 EDT
Created attachment 299784 [details]
firefox debug output

Maybe this makes somebody go "duh! you're doing it wrong!"
Comment 9 Linus Torvalds 2008-03-31 18:48:56 EDT
The gstreamer-plugin thing not only doesn't have sound, but it still leaves the
videos that were all-gray without any video (which is a lot of them). 

That apparently includes the "replay" scene at the end of even working videos,
so the ones that do work (minus the sound) turn gray and useless at the end.

I attached the "-debug" output from a failed video (don't ask me what video it
was, I just picked something at random from the "currently playing" thing, I think).
Comment 10 Charles R. Anderson 2008-03-31 20:11:48 EDT
Hmm I thought you needed gstreamer-plugins-ugly.  Cause that's what caused sound
to work for me, but not video.  Seems I have the opposite problem as you.
Comment 11 Brian Pepple 2008-03-31 20:31:53 EDT
(In reply to comment #10)
> Hmm I thought you needed gstreamer-plugins-ugly.  Cause that's what caused sound
> to work for me, but not video.  Seems I have the opposite problem as you.
> 

Yeah, I'm pretty sure right since the gst-plugins-ugly package has the mp3
(libgstmad.so) plugin.
Comment 12 Charles R. Anderson 2008-03-31 20:37:05 EDT
Yes, it all works for me now--video and audio--with the -ugly plugins and the
gstreamer-ffmpeg package.  Intel GM965 video card, no special settings in Xorg.
 (Why isn't gstreamer-ffmpeg called gstreamer-plugins-ffmpeg?  I would have
found it sooner then.)
Comment 13 Naveed Hasan 2008-04-01 01:48:52 EDT
Here's what I use to workaround the abominable state of x86_64 flash runtimes -

http://www.cs.columbia.edu/~naveed/metubearrrgg

Some other browser plugin that can play FLVs handles the video playback - in my
case, the mozilla plugin for totem-xine on F8.

This has the added benefit of un-rick-rolling all of the youtubes.
Comment 14 Douglas Silas 2008-04-01 02:07:45 EDT
FWIW, the Video DownloadHelper Firefox extension provides a simpler way (toolbar
button) to download flash videos in all their low-fi glory.
Comment 15 David Nielsen 2008-04-01 02:52:47 EDT
Another option is to enable totems youtube plugin and enjoy youtube that way -
naturally still requires codec support.
Comment 16 Mario Torre 2008-04-01 04:25:15 EDT
Hey, you can even use Miro for that :) It's a pretty cool application
Comment 17 Benjamin Otte 2008-04-01 06:05:22 EDT
(In reply to comment #8)
> Created an attachment (id=299784) [edit]
> firefox debug output
> 
> Maybe this makes somebody go "duh! you're doing it wrong!"

This looks like you are using nspluginwrapper. And it looks like it is missing
features that are required for Swfdec.
I'm not sure why it even is installed, as the only reason to use it that I'm
aware of is to make 32bit proprietary Flash plugins run on 64bit machines.
Could you try removing it?
Comment 18 Rahul Sundaram 2008-04-01 09:01:22 EDT
nspluginwrapper is installed because it runs the plugins as a different memory
address allowing SELinux to sandbox plugins. Noted already in the release notes.
If this has any complications with swfdec, let the desktop team know.  
Comment 19 Linus Torvalds 2008-04-01 10:35:55 EDT
Not using nspluginwrapper definitely makes a big difference.

And even sound works now that I realized that it's "plugins-ugly" I needed, not
"plugins-bad". Not very helpful naming.

So this must be a common problem, because nspluginwrapper was installed by
default afaik, and those right gstreamer packages.

I do have a bug still - volume control doesn't work. The slider in the flash
video does nothing (not implemented?), but perhaps more annoyingly, neither does
the normal system slider. I assume that is because swfdec doesn't use
pulseaudio, but goes directly to the alsa interfaces, so I have to use something
like "alsamixer -c0" to get at the actual volume.

Not exactly wife-friendly yet. But this is getting closer!
Comment 20 Keith Waugh 2008-04-01 11:02:54 EDT
I'm running the KDE 4 version of Fedora 9, with the Rawhide, Livna Development
and Adobe repos. I updated/installed latest versions of xine, xine-lib,
xine-lib- extras-nonfree and the flash plugin. No problems playing videos with
sound using xine or Kaffeine. Good luck there.
Comment 21 Bernie Innocenti 2008-04-01 11:34:11 EDT
(In reply to comment #15)
> Another option is to enable totems youtube plugin and enjoy youtube that way -
> naturally still requires codec support.

Or you could yum install the magificient youtube-dl to get the raw video locally.
Comment 22 Brian Pepple 2008-04-01 12:11:10 EDT
(In reply to comment #19)
> And even sound works now that I realized that it's "plugins-ugly" I needed, not
> "plugins-bad". Not very helpful naming.

Yeah, the whole gstreamer-plugin situation if Fedora sucks.  Swfdec upstream had
 implemented support for Codeina that would give the user the option to
install/purchase any missing plugins from Fluendo, but unfortunately just before
the Beta release it was decided to remove Codeina. This is the primary reason we
won't be shippng swfdec installed by default in F9.

> So this must be a common problem, because nspluginwrapper was installed by
> default afaik, and those right gstreamer packages.

I'll talk with our desktop team about whether we should be installing
nspluginwrapper by default.  It probably makes more sense for the Adobe repo to
require nspluginwrapper in their flash plugin package, and not have it installed
by default in Fedora.

> I do have a bug still - volume control doesn't work. The slider in the flash
> video does nothing (not implemented?), but perhaps more annoyingly, neither does
> the normal system slider. I assume that is because swfdec doesn't use
> pulseaudio, but goes directly to the alsa interfaces, so I have to use something
> like "alsamixer -c0" to get at the actual volume.

I'm pretty sure the volume slider isn't implemented in swfdec yet, but Benjamin
would be able to answer that more definitively than I could.

swfdec does have pulse audio support built in, so I'm thinking the system slider
issue your seeing I probably due to our pulse audio packages.  I'll look into
this a bit more later today.
 
> Not exactly wife-friendly yet. But this is getting closer!

Good to hear!
Comment 23 Don Palmigiano 2008-04-01 14:23:02 EDT
Hey, didn't you create Linux? (I know the answer)

Ha Ha, this is so funny.

Linus=Awesome.
Comment 24 Chris 2008-04-01 14:43:16 EDT
for what its worth i'm experiencing the gray box bug also
running ubuntu gusty 7.10
this happened yesterday because (i'm pretty sure) i switched from the non-free
adobe flash to the opensource one.  I installed swfdec also

i'll run through the above and see if any suggestions help me and get back
Comment 25 Erik 2008-04-01 16:43:03 EDT
(In reply to comment #0)

> the wife will kill me
I wonder why she didn't actually do it - sometimes you appear to be an awful 
pighead. *grin*
Comment 26 Warren Togami 2008-04-02 01:03:15 EDT
> I'll talk with our desktop team about whether we should be installing
> nspluginwrapper by default.  It probably makes more sense for the Adobe repo to
> require nspluginwrapper in their flash plugin package, and not have it installed
> by default in Fedora.

They are unlikely to budge on this, because there are other key benefits to
nspluginwrapper even for native 32bit browsers: crashy plugins like Adobe Flash
and others wont take down the entire browser with it.
Comment 27 Charles R. Anderson 2008-04-02 09:47:56 EDT
Re: Comment #17, I'm using nspluginwrapper on x86_64 and swfdec works fine on
youtube:

[cra@l ~]$ ps auxw|grep npviewer

cra      12973 23.7  1.4 344440 56032 ?        S    09:44   0:04
/usr/lib64/nspluginwrapper/npviewer.bin --plugin
/usr/lib64/mozilla/plugins/libswfdecmozilla.so --connection
/org/wrapper/NSPlugins/libswfdecmozilla.so/6154-2


Comment 28 Linus Torvalds 2008-04-02 11:02:22 EDT
Comment #27:
>
>I'm using nspluginwrapper on x86_64 and swfdec works fine on youtube:

So I decided to try some more, and with nspluginwrapper MOST things work, but
not all. For example, I get the gray screen at the end of videos.

This may be connected to SElinux settings, because another difference between
running without nspluginwrapper and running with it is that with nspluginwrapper
I now get the odd 

  "SElinux: AVC denial. Click icon to view"

(I did not use to get this before - so it must have come when I installed the
audio codecs that made sound work) and the details then say

  SELinux is preventing npviewer.bin (nsplugin_t) "unlink" in ./pulse-shm-xxxxxx
(unconfined_tmpfs_t)

so I think this may be some odd interaction with SELinux and nspluginwrapper.

Who are SELinux/nspluginwrapper maintainers for fedora? Can they be cc'd?
Comment 29 Rahul Sundaram 2008-04-02 11:47:41 EDT
Linus, 

I am CC'ing Dan Walsh, SELinux lead and stransky, nspluginwrapper maintainer. 
Comment 30 Michel Alexandre Salim 2008-04-02 21:15:20 EDT
If it's SELinux, then you can test that by doing /usr/sbin/setenforce 0 before 
trying to watch a Youtube video.
Comment 31 Linus Torvalds 2008-04-02 21:39:51 EDT
Using "setenforce 0" does seem to make nspluginwrapper work properly.

Not that I watched very many videos, so it might be random. But it matches the
earlier symptoms, so yeah, I think nspluginwrapper is falling afoul of some
random selinux rule.

Normally I just turn selinux off, but this is a fairly standard Fedora 9 install
with everything default so it happened to be on.
Comment 32 seth vidal 2008-04-04 13:43:39 EDT
Dear Linus,
 From all of us here at the Fedora Project we just wanted you to know we're very
pleased you're testing Fedora 9 and filing bugs. We also wanted to let you know
that we're never gonna give up fixing these bugs.We know when we do our best
we're never gonna let our users down. Sometimes it may feel like it but we're
never gonna give you the run around on these bugs, either. We don't want to
desert you nor you to desert us.

As frustrating as they are we hope we're never gonna make you cry.

Sincerely,
 Seth Vidal
 Fedora Project Board Member.
Comment 33 Paul W. Frields 2008-04-04 15:30:32 EDT
The Board wishes it to be known that:

1. Mr. Vidal has, in the parlance of second-rate spy movies, "gone rogue," and
has posted on behalf of the Board without the required routing through several
committees, endless cross-posted discussion, and explicit approval, and
therefore his pay will be docked accordingly.
2. He is clearly an enormous Rick Astley fan, although he attempts to disguisse
this fact through paraphrase.
3. We love you, Linus!  *scream*
4. We wish for Mrs. Torvalds not to visit pain upon us, and thus thank our
community for stepping in and helping Linus get this bug handled.
5. Because it's Friday, things may get a little silly around here.  Oh, and mind
the gap.

Paul W. Frields
Fedora Project Leader
Comment 34 Daniel Walsh 2008-04-04 15:41:12 EDT
We are in in the midst of trying to confine nsplugin, to allow us to protect the
unconfined user from potential attach from plugins. 

I describe this in:

http://danwalsh.livejournal.com/15700.html

Could you attach the /var/log/audit/audit.log messages.  You can execute 

# setsebool -P allow_unconfined_nsplugin_transition 0

to turn off the transition when executing nsplugin.  This will allow the plugins
to run in the unconfined process just like the rest of login.  We will probably
turn this on as default when we ship Fedora 9, but for now we are trying to find
what problems nsplugin confinement causes.
Comment 35 Nemes Ioan Sorin 2008-04-04 17:36:25 EDT
hmm, not even an intention of flame here, 

I just use Ubuntu from first version - always alpha and beta works. Sometime
with gnu swf I can open some youtube movies (until Flash 9) and now I can play
flv's with almost all players - ( a bunch of codecs on my machine - gstreamer
bad and ugly from my distro repo's ). So is naturally for me to see Youtube with
Firefox (I use also non-open-source flash player from Adobe). Now... all youtube
movies are mine ;).

The point is I don't suggest you to try Ubuntu Hardy beta or Any other *buntu's
mr. Torvalds, but please use not just Bad but Ugly gstreamer codecs - is not
Nvidia or ATI problem - I tested that on all new machines where I put Linux -
after gstreamer ugly codecs installation - all nasty things will work OK with
almost any kind of videocard being Intel, Ati or Nvidia.

My respect, 
Linux for all.

PS: I just transformed point 3 from : "... We love you, Linus!  *scream*..." in
" Thank you dude to turn our history back on the right direction ..., this is
useful now and tomorrow for just few billions..."

SorinN
Comment 36 Daniel Walsh 2008-04-05 08:12:00 EDT
Should be Fixed in selinux-policy-3_3_1-29.fc9


You may stumble onto other errors as we experiment with confining plugins.
Comment 37 firefox 2008-04-08 10:55:37 EDT
Hello world!

Nice joke from Linus Torvals, just a flash video bug stoping her! Lol ;-) If
really good joke on first April. The fish bug of the day! Hey Linus come on
Quebec and get a beer with fan's!

Regards,

RayFox
Qc.Canada  
Comment 38 Scott 2008-04-19 13:32:21 EDT
I knew this had to be a hoax. Linus is a KDE fanboy. :)
Comment 39 Rudolf Kastl 2008-04-21 18:44:39 EDT
(In reply to comment #0)
> Description of problem:
> 
> youtube no workee - fedora 9 not usable for wife
> 
> Version-Release number of selected component (if applicable):
> 
> swfdec.x86_64                 0.6.2-1.fc9
> swfdec-gtk.x86_64             0.6.2-1.fc9
> swfdec-mozilla.x86_64         0.6.0-1.fc9
> 
> 
> How reproducible:
> 
> I didn't try a lot of videos, but I couldn't find a single one that actually
> worked. And what's the internet without the rick-roll?
> 
> Some just show a light gray background, some give the play buttons etc, but show
> only a black screen even when the red ball at the bottom moves along..
> 
> Steps to Reproduce:
> 1. Install current Fedora 9
> 2. Rick-roll!
> 3. No profit!
>   
> Actual results:
> 
> Some videos just show a light gray background, some give the play buttons etc,
> but in the latter case show only a black screen even when the red ball at the
> bottom seems to moves along..
> 
> Expected results:
> 
> Rick Astley in all his glory! People have reported that youtube videos are
> supposed to work with swfdec, so I presume they have worked at some point and
> have been broken recently. 
> 
> Just to test that this isn't just a anti-rick-roll security feature, I also
> tested some other videos, but let's face it - we do need Rick for the "Full
> Internet Experience".
> 
> Additional info:
> 
> This is "high" priority because the wife will kill me if she doesn't have her
> videos. And the adobe player won't install on current rawhide due to some
> library issues.

Adobe flash taints your browser. :)

kind regards,
Rudolf Kastl

> 
> "Obi-wan Kenobi, you're our only hope"

Comment 40 Eduardo Natali 2008-08-13 21:34:09 EDT
Solution to linux youtube problem:

http://ubuntuforums.org/showthread.php?p=5584106#post5584106

Hi,

here i give you the solution to watch movies on youtube with linux 

Distribution: Ubuntu 8.04
Installed Flash player 9 
Close The Mozilla Firefox

steps
1) For Gnome go to: Sistem > Administration > Paquetes Synaptic
2) Search: Gnash
3) The right click, select re-install the following packages:

gnash
gnash-common
gnash-cygal
gnash-tools
klash
konqueror-plugins-gnash
mozilla-plugin-gnash

4) once the packages are selected to be reinstall, click on apply buton
5) Ready, open mozilla firefox an play your movie.

I hope, this will be usefull for you,
Salute,
Eduardo Natali

-------------------------------------------------------------------------------
Solucion problema no funcona youtube en linux:

http://ubuntuforums.org/showthread.php?p=5584106#post5584106

Hola,

Les dejo a continuacion como solucione los problemas para ver los videos de youtube.

Distribucion: Ubuntu 8.04
Tener instalado Flash player, lo pueden bajar desde www.adobe.com
Tener cerrado el firefox

Pasos
1) En Gnome ir a: Sistema > Administracion > Gestor de paquetes Synaptic
2) Buscar: Gnash
3) Con el boton derecho del mouse, marcar para re-instalar los siguientes paquetes:

gnash
gnash-common
gnash-cygal
gnash-tools
klash
konqueror-plugins-gnash
mozilla-plugin-gnash

4) Una vez seleccionados para reinstalar, darle al boton aplicar
5) Abrir mozilla firefox ir a youtube y cuando eligen un video hacen 1 click izquierdo y ya lo tienen andando.

Espero que les sirva,
Saludos Edu..
--------------------------------------------------------------------------------

Note You need to log in before you can comment on or make changes to this bug.