Bug 439873 - Window doesn't close on OK
Summary: Window doesn't close on OK
Status: CLOSED DUPLICATE of bug 437290
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-keyboard   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-31 20:29 UTC by Leon Stringer
Modified: 2009-01-07 18:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 08:27:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leon Stringer 2008-03-31 20:29:00 UTC
Description of problem:
If I load system-config-keyboard to check my configuration and then click OK the
window doesn't close.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.14-1.fc9.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Run System->Administration->Keyboard (enter root password when prompted).
2. In Keyboard window, click OK.
  
Actual results:
Nothing happens

Expected results:
Window closes.

Additional info:
Running in terminal gives a backtrace:

Loading /lib/kbd/keymaps/i386/qwerty/uk.map.gz
Traceback (most recent call last):
  File
"/usr/share/system-config-keyboard/keyboard_gui.py",
line 226, in _okClicked
    return self.apply(None, False)
  File
"/usr/share/system-config-keyboard/keyboard_gui.py",
line 117, in apply
    keyboardBackend.modifyXconfig(fullname, layout,
model, variant, options)
  File
"/usr/share/system-config-keyboard/keyboard_backend.py",
line 34, in modifyXconfig
    keyboard = xf86config.getCoreKeyboard(xconfig)
  File
"/usr/lib/python2.5/site-packages/xf86config.py", line
177, in getCoreKeyboard
    raise XF86SectionMissing("No CoreKeyboard
InputDevice found in the layout")
xf86config.XF86SectionMissing

Comment 1 Fred New 2008-04-07 07:55:23 UTC
This looks the same as bug 437290.

Comment 2 Leon Stringer 2008-04-07 08:27:49 UTC

*** This bug has been marked as a duplicate of 437290 ***


Note You need to log in before you can comment on or make changes to this bug.