Bug 439876 - No kernel packages were installed on your system
No kernel packages were installed on your system
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: booty (Show other bugs)
9
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-03-31 16:37 EDT by Doug Chapman
Modified: 2009-01-27 11:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 11:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-03-31 16:37:13 EDT
Description of problem:
Seen during an install of rawhide on ia64.  Just after installing packages when
it would normally setup the boot loader I get this error:

                    ┌─────────────┤ Warning ├─────────────┐                     
                    │                                     │                     
                    │ No kernel packages were installed   │                     
                    │ on your system.  Your boot loader   │                     
                    │ configuration will not be changed.  │                     
                    │                                     │                     
                    │               ┌────┐                │                     
                    │               │ OK │                │                     
                    │               └────┘                │                     
                    │                                     │                     
                    │                                     │                     
                    └─────────────────────────────────────┘                     

I then boot the installer in rescue mode and verify that the kernel is installed:
sh-3.2# chroot /mnt/sysimage/
sh-3.2# rpm -q kernel
kernel-2.6.25-0.103.rc5.fc9.ia64

so I assume booty is incorrectly thinking the kernel was not installed?

I will try to debug this some more but any suggestions more than welcome.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.64-1
booty-0.103-1.fc9


How reproducible:
only tried once, I will retest


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-03-31 17:37:09 EDT
Looking in anaconda.log I see this as the last few lines:

21:04:55 INFO    : moving (1) to step firstboot
21:04:55 INFO    : moving (1) to step instbootloader
21:04:55 WARNING : Unable to determine kernel type/version for
kernel-2.6.25-0.103.rc5.fc9.ia64


so, might be something funny with this kernel build.  I will build a tree with a
different kernel to see what that does.
Comment 2 Jeremy Katz 2008-03-31 21:56:20 EDT
Fixed in git
Comment 3 Doug Chapman 2008-04-01 08:40:12 EDT
Can we get this fix pushed into CVS?  This is completely blocking Fedora-ia64
progress as we cannot install due to this.
Comment 4 Jeremy Katz 2008-04-01 09:14:17 EDT
Uhhh, what CVS?  anaconda is maintained in git now and has been for about six
months.

But it'll be built for rawhide probably later today as we've been doing builds
mostly at a minimum of every other day.
Comment 5 Bug Zapper 2008-05-14 04:29:02 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.