Bug 439886 - SELinux is preventing npviewer.bin (nsplugin_t) "read" to ./mozpluggerrc (mozilla_conf_t).
SELinux is preventing npviewer.bin (nsplugin_t) "read" to ./mozpluggerrc (moz...
Status: CLOSED DUPLICATE of bug 250249
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-31 17:13 EDT by Matěj Cepl
Modified: 2008-04-01 01:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-31 17:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-03-31 17:13:53 EDT
Description of problem:
When opening Download link
from http://www.bbc.co.uk/worldservice/ I get this AVC denial message:


SELinux is preventing npviewer.bin (nsplugin_t) "read" to ./mozpluggerrc

Podrobný popis:

SELinux denied access requested by npviewer.bin. It is not expected that this
access is required by npviewer.bin and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Povolení přístupu:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for ./mozpluggerrc,

restorecon -v './mozpluggerrc'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Další informace:

Kontext zdroje                unconfined_u:unconfined_r:nsplugin_t:SystemLow-
Kontext cíle                 system_u:object_r:mozilla_conf_t
Objekty cíle                 ./mozpluggerrc [ file ]
Zdroj                         npviewer.bin
Cesta zdroje                  /usr/lib/nspluginwrapper/npviewer.bin
Port                          <Neznámé>
Počítač                    viklef.ceplovi.cz
RPM balíčky zdroje          
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.3.1-26.fc9
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Enforcing
Název zásuvného modulu     catchall_file
Název počítače            viklef.ceplovi.cz
Platforma                     Linux viklef.ceplovi.cz
                              2.6.25-0.163.rc7.git1.fc9.i686 #1 SMP Thu Mar 27
                              09:56:04 EDT 2008 i686 i686
Počet uporoznění           15
Poprvé viděno               Po 31. březen 2008, 22:37:29 CEST
Naposledy viděno             Po 31. březen 2008, 22:46:58 CEST
Místní ID                   8b1d7066-7b64-4de2-8d8a-7bcd75474fa8
Čísla řádků              

Původní zprávy auditu      

host=viklef.ceplovi.cz type=AVC msg=audit(1206996418.239:4244): avc:  denied  {
read } for  pid=24681 comm="npviewer.bin" name="mozpluggerrc" dev=dm-0
ino=2091304 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023
tcontext=system_u:object_r:mozilla_conf_t:s0 tclass=file

host=viklef.ceplovi.cz type=SYSCALL msg=audit(1206996418.239:4244):
arch=40000003 syscall=5 success=no exit=-13 a0=9d2300 a1=0 a2=0 a3=bf8bdd4f
items=0 ppid=24124 pid=24681 auid=500 uid=500 gid=500 euid=500 suid=500
fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=5 comm="npviewer.bin"
subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)

Version-Release number of selected component (if applicable):
as seen on bug 439885
Comment 1 Matěj Cepl 2008-03-31 17:19:04 EDT

*** This bug has been marked as a duplicate of 250249 ***
Comment 2 Daniel Walsh 2008-04-01 01:19:58 EDT
Well this is not really a duplicate of the other bug.

I am removing this label of mozilla_conf_t since it adds no value.

THis will allow nsplugin to read it.

Note You need to log in before you can comment on or make changes to this bug.