Bug 439906 - NGSpice Error: unable to load libraries
NGSpice Error: unable to load libraries
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ngspice (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 18:33 EDT by Damien Schoof
Modified: 2008-04-22 18:36 EDT (History)
0 users

See Also:
Fixed In Version: 3.4.28-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple test circuit to make sure that ngspice simulates properly (116 bytes, text/plain)
2008-03-31 18:33 EDT, Damien Schoof
no flags Details

  None (edit)
Description Damien Schoof 2008-03-31 18:33:23 EDT
Description of problem:
When running ngspice, it is unable to load its component libraries.  Below is
the output when the command ngspice -b test.cir is run:

/usr/lib/spice/spice2poly.cm: undefined symbol: spice2poly_info
Error: Library /usr/lib/spice/spice2poly.cm couldn't be loaded!
/usr/lib/spice/analog.cm: undefined symbol: cm_climit_info
Error: Library /usr/lib/spice/analog.cm couldn't be loaded!
/usr/lib/spice/digital.cm: undefined symbol: cm_adc_bridge_info
Error: Library /usr/lib/spice/digital.cm couldn't be loaded!
/usr/lib/spice/xtradev.cm: undefined symbol: cm_aswitch_info
Error: Library /usr/lib/spice/xtradev.cm couldn't be loaded!
/usr/lib/spice/xtraevt.cm: undefined symbol: ucm_d_to_real_info
Error: Library /usr/lib/spice/xtraevt.cm couldn't be loaded!

Below is a listing of /usr/lib/spice:
-rwxr-xr-x 1 root root 11664 2007-08-24 18:37 analog.cm
-rwxr-xr-x 1 root root 12120 2007-08-24 18:37 digital.cm
-rwxr-xr-x 1 root root 10920 2007-08-24 18:37 spice2poly.cm
-rwxr-xr-x 1 root root 11316 2007-08-24 18:37 xtradev.cm
-rwxr-xr-x 1 root root 11172 2007-08-24 18:37 xtraevt.cm

I have also attached a copy of test.cir; please note, however, that these error
messages occur for any file that I try to simulate (including the example ones).
 This error leaves me unable to do any simulations.

Version-Release number of selected component (if applicable):
ngspice compiled from ng-spice-rework revision 17
Written originally by Berkeley University
Currently maintained by the NGSpice Project

Copyright (C) 1985-1996,  The Regents of the University of California
Copyright (C) 1999-2005,  The NGSpice Projec

How reproducible:
Not sure - this is just the standard installation from the repos - it hasn't
worked since it was installed.  Below is some info about my system:
Linux localhost.localdomain 2.6.24.3-12.fc8 #1 SMP Tue Feb 26 14:58:29 EST 2008
i686 athlon i386 GNU/Linux

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Damien Schoof 2008-03-31 18:33:23 EDT
Created attachment 299781 [details]
Simple test circuit to make sure that ngspice simulates properly
Comment 2 Richard Smith 2008-04-16 05:06:04 EDT
I have also seen this issue on the x86_64 version of ngspice for F8.

Rebuilding the rpm on a fully updated system fixed the problem for me.
Comment 3 Damien Schoof 2008-04-17 00:13:39 EDT
I managed to fix this on my system by recompiling the source and then manually
installing it (make install) - then Ii had no problems.  Must be something in
the distributed rpm.
Comment 4 Chitlesh GOORAH 2008-04-17 02:43:39 EDT
I'll fix it as soon as possible.
Sorry for the delay, I'm having some problems with my pgp key to commit.
Comment 5 Fedora Update System 2008-04-18 02:47:13 EDT
xcircuit-3.4.28-1.fc8,ngspice-17-15.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-04-22 18:36:13 EDT
xcircuit-3.4.28-1.fc8, ngspice-17-15.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.