Bug 439907 - Need to improve and expose SLAPI task API
Summary: Need to improve and expose SLAPI task API
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Server - Plugins   
(Show other bugs)
Version: 1.1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 249650 FDS1.2.0
TreeView+ depends on / blocked
 
Reported: 2008-03-31 22:35 UTC by Nathan Kinder
Modified: 2015-01-04 23:31 UTC (History)
4 users (show)

Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 23:03:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (83.12 KB, patch)
2008-03-31 22:41 UTC, Nathan Kinder
no flags Details | Diff
CVS Commit Messages (2.05 KB, text/plain)
2008-04-03 16:55 UTC, Nathan Kinder
no flags Details

Description Nathan Kinder 2008-03-31 22:35:29 UTC
The current SLAPI task API is lacking in numerous ways.  One of the main issues
is that not all functions and datastructures are exposed via SLAPI that are
needed for writing custom task plug-ins.

A detailed design document for this work is located at:

  http://directory.fedoraproject.org/wiki/Slapi_Task_API

Comment 1 Nathan Kinder 2008-03-31 22:41:57 UTC
Created attachment 299782 [details]
CVS Diffs

These diffs implement the new SLAPI task API that is described in the design
document on the Fedora Directory Server wiki.

Much of the existing API was reused, but new API and cleanup was performed as
well.  I converted the existing server and plug-in tasks to use the new task
API as much as possible.  The exceptions to this are some of the server
internal tasks that call into the backend plug-in.  These tasks work a bit
differently since they can be called as modes of ns-slapd.

Comment 2 Nathan Kinder 2008-04-03 16:55:03 UTC
Created attachment 300281 [details]
CVS Commit Messages

Checked into ldapserver (HEAD).  Thanks to Rich for his review!

Comment 3 Fedora Update System 2008-05-30 22:14:03 UTC
fedora-ds-base-1.1.1-1.fc7 has been submitted as an update for Fedora 7

Comment 4 Fedora Update System 2008-05-30 22:18:18 UTC
fedora-ds-base-1.1.1-1.fc8 has been submitted as an update for Fedora 8

Comment 5 Fedora Update System 2008-05-30 22:19:48 UTC
fedora-ds-base-1.1.1-1.fc9 has been submitted as an update for Fedora 9

Comment 6 Fedora Update System 2008-06-03 07:28:38 UTC
fedora-ds-base-1.1.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2008-06-03 07:32:23 UTC
fedora-ds-base-1.1.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2008-06-03 07:35:38 UTC
fedora-ds-base-1.1.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2008-07-26 06:04:52 UTC
fedora-ds-base-1.1.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Jenny Galipeau 2009-03-17 19:24:02 UTC
Not sure QE can verify this bug, is so - can you please add steps to do so?

Comment 11 Nathan Kinder 2009-03-17 19:28:36 UTC
This can not be verified by QE.  The new API was added and is listed in slapi-plugin.h.

Closing.

Comment 12 Chandrasekar Kannan 2009-04-29 23:03:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html


Note You need to log in before you can comment on or make changes to this bug.