Bug 439912 - b43 keeps reloading firmware
b43 keeps reloading firmware
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 19:01 EDT by Alexei Podtelezhnikov
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.24.6-90.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-03 22:44:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
b43 fixes everything by reloading firmware :) (12.38 KB, text/plain)
2008-04-01 12:01 EDT, Alexei Podtelezhnikov
no flags Details

  None (edit)
Description Alexei Podtelezhnikov 2008-03-31 19:01:43 EDT
Here is some statistics in the best case scenario when I have a very good 
access point at home. b43 is second to ACPI by the amount of generated
messages in the logs.

[apodtele@home ~]$ dmesg | grep -c b43
43

At work this number is more like 843 given a poor access point.

Anyway, why reload firmware 7 times by now? I believe it didn't use to be lke
this. Is driver moving in the wrong direction? Please don't tell me this is
totally normal because it will sound like BSOD is by design.
  
[apodtele@home ~]$ dmesg | grep firmware
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Comment 1 John W. Linville 2008-04-01 09:11:57 EDT
There might be any number of reasons to reload firmware.  A quick perusal of 
the sources suggest that it is reloaded after suspend/resume, when recovering 
from certain errors, when changing some configuration parameters, and probably 
on ifconfig up as well.  I would need your complete dmesg output or contents 
of /var/log/messages and a more thorough description of your scenario to be 
able to comment further.

Are you experiencing real problems?  Or are you simply annoyed by the firmware 
loading messages?
Comment 2 Alexei Podtelezhnikov 2008-04-01 12:01:56 EDT
Created attachment 299918 [details]
b43 fixes everything by reloading firmware :)

No, I don't suspend/resume. I just use my laptop at work.
b43 know one way of dealing with errors: don't think -- reload the firmware.
This attachment contains 41 reloads. Crazy!
Comment 3 Alexei Podtelezhnikov 2008-05-03 22:44:49 EDT
With recent kernel-2.6.24.6-90.fc8.i686, reloads stopped and firmware seems to 
be loaded just once. Cool.  

Note You need to log in before you can comment on or make changes to this bug.