Bug 439915 - ImageMagick C++ library generates assertion failure in RemoveNodeByValueFromSplayTree [NEEDINFO]
ImageMagick C++ library generates assertion failure in RemoveNodeByValueFromS...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ImageMagick (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jan Horak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 19:11 EDT by Geoff Quelch
Modified: 2014-06-03 07:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 07:40:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (quelch)


Attachments (Terms of Use)
Code reproducing the error (1.14 KB, text/plain)
2008-04-01 16:19 EDT, Geoff Quelch
no flags Details

  None (edit)
Description Geoff Quelch 2008-03-31 19:11:31 EDT
Description of problem:
C++ code compiled with ImageMagick++ generates error:
magick/splay-tree.c:903: RemoveNodeByValueFromSplayTree: Assertion `splay_info
!= (SplayTreeInfo *) ((void *)0)' failed.

Version-Release number of selected component (if applicable):
Installed RPMs:
ImageMagick-6.2.8.0-3.el5.4
ImageMagick-devel-6.2.8.0-3.el5.4
ImageMagick-c++-6.2.8.0-3.el5.4
ImageMagick-c++-devel-6.2.8.0-3.el5.4
ImageMagick-c++-devel-6.2.8.0-3.el5.4
ImageMagick-6.2.8.0-3.el5.4
ImageMagick-devel-6.2.8.0-3.el5.4
ImageMagick-perl-6.2.8.0-3.el5.4
ImageMagick-c++-6.2.8.0-3.el5.4

How reproducible:


Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Norm Murray 2008-03-31 20:00:21 EDT
Got some sample code which will show this? 
Comment 2 Geoff Quelch 2008-04-01 13:04:35 EDT
Thanks. I'll try and put together a small test case, or find out I'm making a
mistake with the library... :-)
Comment 3 Geoff Quelch 2008-04-01 16:19:27 EDT
Created attachment 299965 [details]
Code reproducing the error

Compile with:

g++  `Magick++-config --cppflags --cxxflags --ldflags --libs` main.cpp -o
bugtest
Comment 4 Cristy 2008-05-28 20:08:08 EDT
The m_bg_image image object is being accessed before it is defined.  However,
ImageMagick should throw a proper exception rather than an assertion.  The patch
is to only reset the exception signature in DestroyExceptionInfo() of
magick/exception.c if the relinquish member is not 0:

  if (exception->relinquish != MagickFalse)
    exception->signature=(~MagickSignature);

We have this patch in ImageMagick 6.4.1-4 Beta.
Comment 5 Geoff Quelch 2008-05-29 12:27:43 EDT
I have set the size and type of m_bg_image and the code runs without an assertion.
In my full code I am reading in a file to this variable when I got this
exception, does reading in a file not define the object appropriately?
Many thanks.
Comment 6 RHEL Product and Program Management 2014-03-07 07:43:44 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-03 07:40:33 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.