Bug 439924 - ath5k not detecting networks
Summary: ath5k not detecting networks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-31 23:47 UTC by Andrew Alm
Modified: 2008-05-05 17:12 UTC (History)
2 users (show)

Fixed In Version: 2.6.25-14.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 17:12:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (49.42 KB, text/plain)
2008-03-31 23:47 UTC, Andrew Alm
no flags Details
/var/log/messages (1.05 MB, text/plain)
2008-03-31 23:48 UTC, Andrew Alm
no flags Details
a newer dmesg (44.29 KB, application/octet-stream)
2008-04-12 19:52 UTC, Andrew Alm
no flags Details

Description Andrew Alm 2008-03-31 23:47:22 UTC
Description of problem:
After installing fedora 9 beta, ath5k has seemed to stop wroking for me.  I was
having very few problems in fedora 8 but now no networks show up in network
manager and "iwlist wlan0 scanning" nets no results.

Version-Release number of selected component (if applicable):

kernel 2.6.25-0.172.rc7.git4.fc9.x86_64

using an atheros AR5212 802.11abg NIC

How reproducible:


Steps to Reproduce:
1.install fedora 9
2.attempt to connect to a wireless network
  
Actual results:
no wireless networks found, cannot connect manually.

Expected results:
a list of wireless networks, abilitiy to connect to a specific network

Comment 1 Andrew Alm 2008-03-31 23:47:22 UTC
Created attachment 299794 [details]
dmesg output

Comment 2 Andrew Alm 2008-03-31 23:48:21 UTC
Created attachment 299795 [details]
/var/log/messages

Comment 3 John W. Linville 2008-04-01 13:17:24 UTC
Please attach the output of running 'iwlist wlan0 scan'...thanks!

Comment 4 Andrew Alm 2008-04-03 01:23:23 UTC
Don't know how much this will help but here it is in all its glory :-D....

[root@thinktank ~]# iwlist wlan0 scan
wlan0     No scan results

I don't think it is an issue with just NetworkManager or something since this
way doesn't find any wireless networks (and there are plenty around me).

Comment 5 John W. Linville 2008-04-03 20:23:08 UTC
Ah, ok...do you recall what was the last F8 kernel that worked?

Comment 6 Andrew Alm 2008-04-03 20:33:28 UTC
Looking at https://admin.fedoraproject.org/updates/kernel it would appear that
the last kernel I used in F8 was kernel-2.6.24.3-50.fc8.  If not then
kernel-2.6.24.3-34.fc8 definately worked.  I only upgraded to F9 beta a few days
ago so it should be that first kernel.

Comment 7 John W. Linville 2008-04-07 13:20:45 UTC
Hmmm...there is a patch between -34.fc8 and -50.fc8 that touched ath5k, but 
none since then.

The first rawhide kernel that had the ath5k patch in question of 
2.6.25-0.120.rc5.git3.fc9:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42933

And the one before that was 2.6.25-0.113.rc5.git2.fc9:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42641

Could you test those two kernels to see if one had the problem and the other 
does not?  Thanks!

Comment 8 Andrew Alm 2008-04-12 19:46:59 UTC
Sorry about the delay in getting back to you been a bit busy.  Niether of those
kernels seem to solve the problem.  If I have some time later today or tomorrow
I'll try some other kernels that have had changes in the ath5k driver.  It
almost seems like the radio is just off or something...

Comment 9 Andrew Alm 2008-04-12 19:52:05 UTC
Created attachment 302238 [details]
a newer dmesg

I noticed some new messages in dmesg about ath5k that I don't think were there
when I opened this bug... maybe this will provide some more clues.

Comment 10 Andrew Alm 2008-05-04 22:24:40 UTC
It seems to be working now... I think a newer kernel took away this problem.

Comment 11 John W. Linville 2008-05-05 16:01:13 UTC
Ah, thanks!  What kernel are you running now?

Comment 12 Andrew Alm 2008-05-05 16:34:58 UTC
I am on 2.6.25-14.fc9.x86_64, this message is coming from my backyard wirelessly
:-D.


Note You need to log in before you can comment on or make changes to this bug.