Bug 439945 - e1000 should not be default NIC
e1000 should not be default NIC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 22:21 EDT by Andrew Bartlett
Modified: 2008-04-01 09:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 09:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2008-03-31 22:21:22 EDT
Description of problem:
e1000 NIC is should not be the default, because WinXP does not have a driver for
it, by default. 

Version-Release number of selected component (if applicable):
kvm-64-2.fc9

How reproducible:
Every time

Steps to Reproduce:
1.  Install KVM from rawhide on Fedora 8
2.  Boot WinXP or Linux
  
Actual results:
WinXP:  Popup to say 'new hardware found' but no driver is found
Linux: lspci shows this is not rtl8139 as expected

Expected results:
rtl8139 for maximum compatability

Additional info:
If we wish to use the new driver (say to get better IO with the guest), it
should be selected on the kvm command line, perhaps set by libvirt and the
installer based on selected OS, not by default. 

If this was in tandem with some libvirt/virt-manger change, then a conflicts in
the RPM is required.
Comment 1 Kevin Fenzi 2008-03-31 23:01:11 EDT
Yeah, I agree thats less than ideal...

However, the e1000 driver is a great deal better for any kind of modern linux
guest. ;( 

Ideally we could get libvirt to allow this to be set on a per guest basis, 
perhaps even defaulting on xp guests to rtl8139 and e1000 for linux guests. 

Any opinions from the libvirt folks?
Comment 2 Daniel Berrange 2008-04-01 00:02:26 EDT
That's certainly doable, but not for F9 given that we're way past feature freeze.
Comment 3 Jeremy Katz 2008-04-01 09:54:31 EDT
That's why we changed it early was so we could learn about any problems like
this.  Changing it back to rtl8139 for now... hopefully the relevant
libvirt/virt-manager bits can get done for Fedora 10 

Note You need to log in before you can comment on or make changes to this bug.