Bug 439951 - PolicyKit default
PolicyKit default
Status: CLOSED DUPLICATE of bug 439844
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 22:51 EDT by Rahul Sundaram
Modified: 2013-03-13 01:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 06:43:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-03-31 22:51:28 EDT
Description of problem:

GPK uses policy kit and the default is set to retain the authentication
permanently. I think that is unexpected behaviour. The default should be just to
retain the authentication for the current session. I would prefer a option to
retain for something like 10 minutes and the option to revoke it via a sys tray
applet like how it was before.  

Additional info:

This is potentially a policy kit issue. Feel free to reassign if that's the case.
Comment 1 Matthias Clasen 2008-04-01 01:54:00 EDT
You _can_ revoke your authorizations using polkit-gnome-authorization.
But that is hardly a user-friendly solution. David had some plans to write an
enduser frontend for authorization handling, but I don't know when that will
show up.
Comment 2 Richard Hughes 2008-04-01 06:43:02 EDT

*** This bug has been marked as a duplicate of 439844 ***

Note You need to log in before you can comment on or make changes to this bug.