Bug 439952 - Only the "Make certification public" checkbox should mark all previous comments to private
Only the "Make certification public" checkbox should mark all previous commen...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: web site (Show other bugs)
beta
All Linux
medium Severity low
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 22:53 EDT by YangKun
Modified: 2008-06-23 03:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: (2.18rh) 2008/05/23 push
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 03:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch to fix this bug (859 bytes, patch)
2008-04-14 04:10 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description YangKun 2008-03-31 22:53:36 EDT
Description of problem:

currently there're two checkboxes in our catalog controlling whether to public a
cert: the "Make certification public" and "TAM ACK". a cert can be public only
when both checkboxes were clicked.

and only the "Make certification public" checkbox should mark all previous
comments to private. However this is not true. Current catalog behaviour is: if
"Make certification public" is clicked first, the previous public comments will
NOT be changed to private, they'll be backed to private only when both "Make
certification public" and "TAM ACK" are clicked.
Comment 1 YangKun 2008-04-14 03:05:44 EDT
turns out that "TAM ACK" will not mark all previous comments to private. the
real problem is: once "Make certification public" is provided, any further
changes(the "Save Changes" was clicked) in the cert will mark all previous
comments to private.

But the expected behaviour should be: only the first time when we "Make
certification public" mark all preivous comments to private, any further changes
in that cert should not change the status of previous comments.
Comment 2 XINSUN 2008-04-14 04:09:35 EDT
Yk, 
  The patch to fix this bug is attached. and my ~/xisun2 tree on bugdev have
patch  ed it and you can test it as your need.

Best Regards!
Nicho
Comment 3 XINSUN 2008-04-14 04:10:17 EDT
Created attachment 302309 [details]
The patch to fix this bug
Comment 4 YangKun 2008-04-14 04:44:24 EDT
Nicho,

That's quick! Thanks :)

I verified this change on -xisun2
(http://bugdev.devel.redhat.com/hwcert-xisun2/show.cgi?id=429952)

It works as expected: after the "Make certification public" is checked, all
further changes(the "Save Changes" was clicked) in the cert won't mark all
previous comments to private(including the "TAM Ack").

Rob, can we get this patch into the live catalog ?

Thanks
-YK
Comment 5 XINSUN 2008-05-14 09:38:31 EDT
Patch has been summited into cvs.

Note You need to log in before you can comment on or make changes to this bug.