Bug 439955 - libvirt should record OS type
Summary: libvirt should record OS type
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-01 03:07 UTC by Andrew Bartlett
Modified: 2008-04-01 04:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 04:08:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Bartlett 2008-04-01 03:07:17 UTC
Description of problem:
The selected operating system type (set when installing an OS in virt-manager)
should be stored.

Version-Release number of selected component (if applicable):
libvirt-0.4.1-2.fc
virt-manager-0.5.3-2.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Install new virtual machine with virt-manager
2. Select OS Windows -> Windows XP
3. Finish installation
  
Actual results:
No information that this was WinXP included in the XML output in /etc/libvirt/qemu

Expected results:
Additional metadata included in the XML description, to assist in the future

Additional info:
While changing the default or post-installation virtual environment must be
avoided if at all possible, storing the additional metadata may allow defaults
to change differently for different OS types.  (And therefore a better upgrade
experience).

(eg kvm moving from rtl8139 to e1000 was harmless for linux, but painful on WinXP)

Comment 1 Daniel Berrange 2008-04-01 04:08:38 UTC
The OS type information is only intended to be used for the initial VM
provisioning step, primarily to assist in handling the install media, and as a
secondary task to help choose some sensible default settings. Post-install,
adminstrators are intended to have full control over all settings without
virt-manager second guessing them. As such OS type is irrelevant post-install -
the administrator should decide what NIC type is relevant for them.

Furthermore, even if we wanted to store OS type we can't because some of the
hypervisors we have to handle do not support such a concept as a persistent setting.


Note You need to log in before you can comment on or make changes to this bug.