Bug 439959 - RFE: xdg autostart instead of gnome autostart?
Summary: RFE: xdg autostart instead of gnome autostart?
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-01 03:26 UTC by Kevin Fenzi
Modified: 2013-03-06 03:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 09:20:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Fenzi 2008-04-01 03:26:43 UTC
Currently, gnome-power-manager is started via it's 
/usr/share/gnome/autostart/gnome-power-manager.desktop
file. 

Would it be possible to move that or add a /etc/xdg/autostart/ desktop file?

This would allow it to be started and used by Xfce users in addition to gnome
users. 

Thoughts?

Comment 1 Jon Stanley 2008-04-23 20:29:53 UTC
Adding FutureFeature keyword to RFE's.

Comment 2 Richard Hughes 2008-04-30 09:20:16 UTC
Please open an upstream GNOME bug, this is not the place to do feature
enhancements to upstream. Thanks!

Comment 3 David Zeuthen 2008-04-30 14:50:59 UTC
(In reply to comment #0)
> Would it be possible to move that or add a /etc/xdg/autostart/ desktop file?
> 
> This would allow it to be started and used by Xfce users in addition to gnome
> users. 

And then it would autostart in KDE if people have both KDE and GNOME installed.
So this is not a good idea neither upstream nor in the Fedora g-p-m package.
It's better for Fedora's XFCE packages just to ship it's own autostart file and
require the g-p-m package.

Comment 4 Rex Dieter 2008-04-30 15:06:10 UTC
srsly?  Shouldn't one be able to simply install this, and have it "just work",
regardless of DE?

Regardless, upstream *is* the place for this to happen (or not).

Comment 5 David Zeuthen 2008-04-30 15:30:00 UTC
(In reply to comment #4)
> srsly?  Shouldn't one be able to simply install this, and have it "just work",
> regardless of DE?

No, KDE ships with it's own power management utilities and by the same token I
don't want these to start when logging into GNOME just because I happen to have
KDE installed. 

It's for the same reasons we have OnlyShowIn= etc. in the desktop entry spec.


Comment 6 Rex Dieter 2008-04-30 15:41:03 UTC
imo OnlyShowIn= should be reserved for tools that are truly DE-specific, but
that's just me.

Comment 7 David Zeuthen 2008-04-30 16:20:08 UTC
(In reply to comment #6)
> imo OnlyShowIn= should be reserved for tools that are truly DE-specific, but
> that's just me.

I think gnome-power-manager is truly DE-specific. Not just the name, also the
deps and integration with gnome-screensaver.

Comment 8 Kevin Fenzi 2008-04-30 16:57:08 UTC
Well, I have been happily using gnome-power-manager on my Xfce desktop for many
years and it's been working great for me. ;) 

In any case, you are correct. I will take this upstream... thanks. 



Note You need to log in before you can comment on or make changes to this bug.