Bug 439968 - virt-manager does not check for disk space
virt-manager does not check for disk space
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1.z
All Linux
medium Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 01:00 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 15:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2008-04-01 01:00:09 EDT
Description of problem:
virt-manager does not check to see if there is adequate disk space in the target
directory/mount point when installing to simple file.


Version-Release number of selected component (if applicable):
virt-manager-0.4.0-3.el5


How reproducible:
always

Steps to Reproduce:
1. note amount of disk space in /opt
2. create a new vm disk in /opt that exceeds the free space.
3. virt-manager is happily start allocating blocks and then fails the complete
disk creation due to lack of space
  
Actual results:


Expected results:

1. should check for free space in target directory
2. - provide error condition and option to reselect location and/or size
Comment 1 Daniel Berrange 2008-04-01 10:03:15 EDT
This will be addressed in virt-manager-0.5.3 scheduled for RHEL-5.2
Comment 2 Cole Robinson 2008-06-23 15:42:23 EDT
I've verified that is fixed in 5.2, so I'm closing this as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.